Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Audio/Sound
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-04-2010, 05:05 PM   #1
2k328Ci
2nd Gear Member
 
Join Date: Nov 2005
Location: Toronto
Posts: 63
Question Help, deteriorating AM radio with BMW Business CD headunit...

Hi all,

I have a 2000 328Ci with the orignal BMW Business CD headunit. I find myself listening to AM radio more and more and have noticed that whenever I turn on my rear window defrosters, the AM reception goes haywire and all I get is static. Now without the defrosters I find that I am getting deteriorating AM reception. Is there a lose antenna connection somewhere I can check? I think the top portion of the rear defroster lines are the AM antenna, but shouldn't there be some kind of filter that kicks in when the defrosters are on? Is there a connector at the rear windshield that I can check (I can't see one without taking the headliner out)? How should I start to trouble shoot this problem? Is there a good place/shop to take this problem to?

Thanks,
Wm
__________________
2000 BMW 328Ci w/ Premium Sports Pkg, Type 68 OEM M-rims (summer), Type 67 replica M-rims (winter)
HK Premium Sound, Dension IceLink Plus (Stealth), Predator Chromiums 6000K, Tint & OEM Clears :}:
2k328Ci is offline   Reply With Quote
Old 05-06-2010, 06:05 PM   #2
uzi577
RUNING BOOST
 
uzi577's Avatar
 
Join Date: May 2009
Location: Toronto
Posts: 258
Quote:
Originally Posted by 2k328Ci View Post
Hi all,

I have a 2000 328Ci with the orignal BMW Business CD headunit. I find myself listening to AM radio more and more and have noticed that whenever I turn on my rear window defrosters, the AM reception goes haywire and all I get is static. Now without the defrosters I find that I am getting deteriorating AM reception. Is there a lose antenna connection somewhere I can check? I think the top portion of the rear defroster lines are the AM antenna, but shouldn't there be some kind of filter that kicks in when the defrosters are on? Is there a connector at the rear windshield that I can check (I can't see one without taking the headliner out)? How should I start to trouble shoot this problem? Is there a good place/shop to take this problem to?

Thanks,
Wm
The reception will go bad if you tint you car with metalic tins.
uzi577 is offline   Reply With Quote
Old 05-06-2010, 06:56 PM   #3
2k328Ci
2nd Gear Member
 
Join Date: Nov 2005
Location: Toronto
Posts: 63
Thanks, good to know - I just have regular non-metallic tints (very light).
__________________
2000 BMW 328Ci w/ Premium Sports Pkg, Type 68 OEM M-rims (summer), Type 67 replica M-rims (winter)
HK Premium Sound, Dension IceLink Plus (Stealth), Predator Chromiums 6000K, Tint & OEM Clears :}:
2k328Ci is offline   Reply With Quote
Old 05-07-2010, 12:54 PM   #4
Randy
2nd Gear Member
 
Randy's Avatar
 
Join Date: May 2008
Location: At home.
Posts: 237
I also have this problem. My car is a 1999 323i. Someone, please help!
Randy is offline   Reply With Quote
Old 05-07-2010, 01:57 PM   #5
2k328Ci
2nd Gear Member
 
Join Date: Nov 2005
Location: Toronto
Posts: 63
I got some great tips over here at e46toronto;
http://www.e46toronto.ca/forums/showthread.php?t=15634

That I want to try out this weekend if the weather co-operates.
__________________
2000 BMW 328Ci w/ Premium Sports Pkg, Type 68 OEM M-rims (summer), Type 67 replica M-rims (winter)
HK Premium Sound, Dension IceLink Plus (Stealth), Predator Chromiums 6000K, Tint & OEM Clears :}:
2k328Ci is offline   Reply With Quote
Old 05-07-2010, 11:46 PM   #6
Randy
2nd Gear Member
 
Randy's Avatar
 
Join Date: May 2008
Location: At home.
Posts: 237
read them. great stuff. Looks like i've got another project on my hands. thanks for all the info.
Randy is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:59 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014