Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-30-2010, 11:27 AM   #1
mahniak
2nd Gear Member
 
Join Date: Nov 2009
Location: Quebec
Posts: 75
RPM going crazy !

So i was just driving around when my RPM started going crazy, goes from 0 to 7000 back and forth and its been doing this for the last day.
any ideas ?
mahniak is offline   Reply With Quote
Old 01-30-2010, 03:35 PM   #2
nachos23
SweetXi
 
nachos23's Avatar
 
Join Date: Jun 2009
Location: Brampton, Ontario
Posts: 966
Send a message via MSN to nachos23
throttle position sensor? Any codes?
nachos23 is online now   Reply With Quote
Old 01-31-2010, 11:23 PM   #3
mahniak
2nd Gear Member
 
Join Date: Nov 2009
Location: Quebec
Posts: 75
no codes, the engine is running fine no problems at all, its only the gauge that is going crazy it's gonna be fine for a while then i hit a bump and it starts going crazy again until theres another bump
mahniak is offline   Reply With Quote
Old 01-31-2010, 11:42 PM   #4
Mad Cow
2nd Gear Member
 
Join Date: Sep 2009
Location: Toronto
Posts: 184
Pull out the cluster and re-connect all of the connectors. My fuel and temp gauges used to be weird (used to drop to 0 randomly or jump around), then I noticed that they went back to normal for a few seconds if I smacked the dash above them. I pulled the cluster to replace some bulbs and now I haven't had a single issue with them.
Mad Cow is offline   Reply With Quote
Old 02-01-2010, 12:14 AM   #5
mahniak
2nd Gear Member
 
Join Date: Nov 2009
Location: Quebec
Posts: 75
Yes same thing when i hit it it goes normal a bit, so I guess I'll do what you said once the temperature rises -30 C is a bit too cold to be doing that
mahniak is offline   Reply With Quote
Old 02-03-2010, 11:27 PM   #6
aaron320i
Banned
 
Join Date: Oct 2009
Location: Mississauga
Posts: 416
Send a message via MSN to aaron320i
Change the cluster. Common problem.
aaron320i is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014