Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-04-2009, 12:07 AM   #1
davericher20
black and blue
 
davericher20's Avatar
 
Join Date: Dec 2006
Location: 2 storey 3 bedroom 1 car garage
Posts: 3,584
new pics (and problems) of my ix Touring

So, after completing the timing belt change and buying new rims on impulse. Drove it from cambridge to bradford to Lindsay and back this weekend......

Still some issues, it vibrates like a muhfuhuh, only at like 60 and 80km/hr

And the big issue is it cuts out when I'm accellerating, it will lose power for half a second and go back to normal, then do it again randomly 10 minutes later, mostly on hills but still under normal accelleration. It's always done this.

the most accurate description I can give you is this

1st gear-braaaaaaaaaaaap
2nd gear braaaaaaaaaaaaaaaaaaaaaaaaa_put_aaaaaaap
3rd gear-braaaaaaaaaaaaaa_put_aaaaa_put_aaaaaaaaaaaap

I don't have an oxygen sensor......but I don't think that's it, it feels like there's a short supply in fuel or something.

anyways, here's some pics from the g-friends rents trailer.





I took off the headlight wipers for now.














here's what my other rims looked like

__________________


Quote:
Originally Posted by JINT View Post
Some people have serious track experience from the cruise, so what is fast to you, isn't fast to them.

Last edited by davericher20; 08-04-2009 at 01:04 AM.
davericher20 is offline   Reply With Quote
Old 08-04-2009, 12:13 AM   #2
dble Trouble
TAKE IT TO THE TRACK
 
dble Trouble's Avatar
 
Join Date: Nov 2005
Location: Scarborough
Posts: 1,853
That is without a doubt, one of the sexiest cars on Max!
dble Trouble is offline   Reply With Quote
Old 08-04-2009, 12:36 AM   #3
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,774
[quote=davericher20;1331841]
I don't have an oxygen sensor......but I don't think that's it, it feels like there's a short supply in fuel or something.

QUOTE]

lol the only purpose of the 02 sensor is to tell if your car is running rich/lean...So if you dont have one, what do you think is helping adjust the mixture!!!

It could be other things too, but fix the obvious first!
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E34 E39 E60 E32 E38 E65 E66 X5 M3 M5


Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is online now   Reply With Quote
Old 08-04-2009, 12:48 AM   #4
davericher20
black and blue
 
davericher20's Avatar
 
Join Date: Dec 2006
Location: 2 storey 3 bedroom 1 car garage
Posts: 3,584


















__________________


Quote:
Originally Posted by JINT View Post
Some people have serious track experience from the cruise, so what is fast to you, isn't fast to them.

Last edited by davericher20; 08-04-2009 at 01:05 AM.
davericher20 is offline   Reply With Quote
Old 08-04-2009, 12:52 AM   #5
davericher20
black and blue
 
davericher20's Avatar
 
Join Date: Dec 2006
Location: 2 storey 3 bedroom 1 car garage
Posts: 3,584


google translator......."auto kit"















__________________


Quote:
Originally Posted by JINT View Post
Some people have serious track experience from the cruise, so what is fast to you, isn't fast to them.

Last edited by davericher20; 08-04-2009 at 01:09 AM.
davericher20 is offline   Reply With Quote
Old 08-04-2009, 02:28 AM   #6
archins
2nd Gear Member
 
Join Date: Jul 2009
Location: LATVIA
Posts: 88
Send a message via Skype™ to archins
Quote:
Originally Posted by davericher20 View Post
So, after completing the timing belt change and buying new rims on impulse. Drove it from cambridge to bradford to Lindsay and back this weekend......

Still some issues, it vibrates like a muhfuhuh, only at like 60 and 80km/hr

And the big issue is it cuts out when I'm accellerating, it will lose power for half a second and go back to normal, then do it again randomly 10 minutes later, mostly on hills but still under normal accelleration. It's always done this.

the most accurate description I can give you is this

1st gear-braaaaaaaaaaaap
2nd gear braaaaaaaaaaaaaaaaaaaaaaaaa_put_aaaaaaap
3rd gear-braaaaaaaaaaaaaa_put_aaaaa_put_aaaaaaaaaaaap

I don't have an oxygen sensor......but I don't think that's it, it feels like there's a short supply in fuel or something.
My friend have the same problem and it starts when he cut out oxygen sensor, than he put back and problem was gone
your car rims 16 or 17 inch ????? I have the same car like you (copy)
__________________

BMWMPOWER.LATVIA

Last edited by archins; 08-04-2009 at 02:35 AM.
archins is offline   Reply With Quote
Old 08-04-2009, 09:08 AM   #7
davericher20
black and blue
 
davericher20's Avatar
 
Join Date: Dec 2006
Location: 2 storey 3 bedroom 1 car garage
Posts: 3,584
Quote:
Originally Posted by archins View Post
My friend have the same problem and it starts when he cut out oxygen sensor, than he put back and problem was gone
your car rims 16 or 17 inch ????? I have the same car like you (copy)
okay, we'll see about the sensor then. I hope that's the problem.

Those are 17 inch rims.

So do you have an ix Touring? or an i?
__________________


Quote:
Originally Posted by JINT View Post
Some people have serious track experience from the cruise, so what is fast to you, isn't fast to them.
davericher20 is offline   Reply With Quote
Old 08-04-2009, 09:20 AM   #8
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,629
So nice. I can't wait to get an e30 touring, I have a secret obsession with them. Mark my words I will have one within the next 2 years lol. I know there's a couple for sale around here but they are not exactly what I want. I'll be going to Germany to find that...

ps fix that deck install, it looks horrendous.
__________________
Bullet Ride is online now   Reply With Quote
Old 08-04-2009, 09:37 AM   #9
davericher20
black and blue
 
davericher20's Avatar
 
Join Date: Dec 2006
Location: 2 storey 3 bedroom 1 car garage
Posts: 3,584
lol, I removed it to get to a switch above it, since it was a pain in the ass to remove it I just left it out a bit..........it goes in all the way don't worry. FYI it's not staying, have another system to go in.
__________________


Quote:
Originally Posted by JINT View Post
Some people have serious track experience from the cruise, so what is fast to you, isn't fast to them.
davericher20 is offline   Reply With Quote
Old 08-04-2009, 12:02 PM   #10
archins
2nd Gear Member
 
Join Date: Jul 2009
Location: LATVIA
Posts: 88
Send a message via Skype™ to archins
I have the same year iX
__________________

BMWMPOWER.LATVIA
archins is offline   Reply With Quote
Old 08-04-2009, 12:22 PM   #11
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,829
Details on wheels / tires? Size, offset, etc.
__________________
everlast is offline   Reply With Quote
Old 08-04-2009, 12:43 PM   #12
Duct_Taper
Sticky
 
Duct_Taper's Avatar
 
Join Date: Oct 2008
Location: Ottawa
Posts: 601
Quote:
Originally Posted by everlast View Post
Details on wheels / tires? Size, offset, etc.
+1

What wheels are they? Where did you get them? Etc.
Duct_Taper is offline   Reply With Quote
Old 08-04-2009, 01:12 PM   #13
archins
2nd Gear Member
 
Join Date: Jul 2009
Location: LATVIA
Posts: 88
Send a message via Skype™ to archins
Quote:
Originally Posted by everlast View Post
Details on wheels / tires? Size, offset, etc.
all most full, don't have cruise and electr. sunroof, Wheels BROCK B1 R16 all 4 J9 offset ~15 tires front 195/45 rear 215/40, black roof, bilstien shocks, try to lower but need cut shorter shocks
other foto
__________________

BMWMPOWER.LATVIA
archins is offline   Reply With Quote
Old 08-04-2009, 01:24 PM   #14
archins
2nd Gear Member
 
Join Date: Jul 2009
Location: LATVIA
Posts: 88
Send a message via Skype™ to archins
Quote:
Originally Posted by everlast View Post
Details on wheels / tires? Size, offset, etc.
__________________

BMWMPOWER.LATVIA
archins is offline   Reply With Quote
Old 08-04-2009, 01:42 PM   #15
lost
2nd Gear Member
 
lost's Avatar
 
Join Date: Feb 2005
Location: Windsor Area
Posts: 285
Same wheels I'm running on my touring. Brock Autofashion b1's as mentioned above.

davericher20; your car looks great!! nice a fresh and clean. I'm having an electrical problem with my battery being drained but as the previous owner was a hack in the wiring department. Have a new-used harness untouched that I'm going to be swapping in also.

I see your battery is in the back? Did you relocate it? Mines an 88 i and it's located under the hood.

Also the new rims look great!! big improvement over the old.

I've got mine forsale right now but after seeing yours I think I might just keep it.

Gotta love everything in German, whenever a light pops on I have to call my wife and get her to translate it via google. lol

Anyways car looks sweet.
lost is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.