Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-16-2009, 03:30 PM   #1
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
Idle issues 88 ix

On cold or warm start up it will hang at about 1500rpm for about 20 seconds, then drops to about 1000 and stays there hot or cold.
The odd time(every 30 seconds or so) it will stumble a bit and drop to 700 momentarily, then back up.
Also feels slightly underpowered.
When I blip on/off the throttle just a tiny bit, it will go up(lets say to 1500rpm) and will hang there a few seconds before coming down. This will happen repeatedly.
Engine revs up to speed no problem.

Looked for vacuum leak, nothing obvious. Has new plugs and wires, alternator and battery.

Looking to get this damn idle issue sorted soon. Whos got ideas?
Cheers.
Rob
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-16-2009, 03:38 PM   #2
e30_kid89
The Afro-stig
 
e30_kid89's Avatar
 
Join Date: Nov 2005
Location: TDot West End
Posts: 4,589
Send a message via MSN to e30_kid89
Did ya clean out the ICV good? If you shake it the thingy inside should move freely.
__________________
e30_kid89 is offline   Reply With Quote
Old 03-16-2009, 04:55 PM   #3
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,693
Send a message via MSN to propr'one
Actually having a similar problem on my iX. I adjusted my idle screw to bump the idle up, and its higher (mabye too high), but now it idles very strange. Greg told me the TPS probably isn't lined up, but i feel like i probably have more than one problem.
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is online now   Reply With Quote
Old 03-16-2009, 06:26 PM   #4
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
ha, maybe
ok, im going to go shake the shit out of my icv
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-16-2009, 09:46 PM   #5
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
icv seemed to move freely. any other ideas?
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-17-2009, 07:57 AM   #6
richie_s999
6th Gear Member
 
Join Date: Sep 2008
Location: Oshawa
Posts: 4,537
how cleans the intake system? Get some intake cleaner in an arosel, spary the can into the throttle body with car running, that will clean off sensors, valves, plugs ect. The sparys like $10 a can at the GM dealers (its all the same product at every dealer) Takes about 30 minutes to do the procedure, and see how she's idling. This is basically what the dealers charge $150 for - intake cleaning gets all the carbon and oil build up outa the intake, so if anything ius gunked up this should help.
richie_s999 is offline   Reply With Quote
Old 03-17-2009, 08:39 AM   #7
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
you think maybe my tps is messed up?
What about my temp sensor too? The cluster gauge shows cold thru warm as it should, but the idle speed does not change when its warmed up.
Replaced the sensor for the gauge recently but the other sensor is untouched. I am sure there are hot/cold resistance values for this sensor somewhere. Anyone know where I can find it.
I think it might be running a slight bit rich too.
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-17-2009, 12:52 PM   #8
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
ok, did a bit of a cleanout of the intake, and changed the throttle cable.
When i first started it up, it sat at 1500rpm for about 20 secs, then went down by 50rpm or so every 5 seconds, till it started to misfire and chug. I held it at about 2500 for a minute and now its idling smoothly at 1100, barely stuttering but still high and its currently at temp(or just below).
Just checked the resistance at the blue temp sensor(car off) and it was at 380 and climbing slowly as the car cools.

ideas?
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-18-2009, 03:03 PM   #9
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
nobody?
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-18-2009, 04:56 PM   #10
slimjim
Almost Sideways
 
Join Date: Nov 2007
Location: canada
Posts: 1,876
what plugs are you running?
__________________
slimjim is offline   Reply With Quote
Old 03-18-2009, 04:57 PM   #11
SamE30e
6th Gear Member
 
SamE30e's Avatar
 
Join Date: Jul 2007
Location: Milton
Posts: 2,870
Seaaafoammmmm!
__________________
91 318is - M50NV (gone)
02 WRB Subaru WRX EJ207 forged, 320 AWHP stock turbo.
85 - 325
02 325i Sedan
SamE30e is offline   Reply With Quote
Old 03-18-2009, 05:35 PM   #12
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
I'm using the champion coppers from Napa.

i guess seafoam may be in order here. I can pick this type of shit up where(Napa, CT, Dealer)? What brand or does it have a name its known as?
I've seen it done on youtube several times, im not terribly worried about how to do it. just need to find out what and where.
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-22-2009, 12:29 PM   #13
e30jones
3rd Gear Member
 
Join Date: Mar 2004
Location: Lindsay, ON
Posts: 312
Seafoam is the brand. I believe that carquest sells it, not 100% positive though, I haven't been able to find it anywhere else. You can substitute other things for seafoam, water will also work (although maybe not as well), and some people use ATF too. GM sells an upper combustion chamber cleaner that is similar I believe.
e30jones is offline   Reply With Quote
Old 03-22-2009, 03:26 PM   #14
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
i picked up some Seafoam brand Seafoam from PartsSource for $12 Will be trying it tomorrow.
On a side note, idle is definitely smoother on 91oct, duh, but still high at 1100. Swapped ICV with another known good one and same results.
Waiting on results of Seafoam.
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 03-28-2009, 06:51 PM   #15
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
seafoamed it today, it was clean, no change at all.
will be swapping AFM later tonight or tomorrow morning to see if it helps.
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:37 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.