Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-11-2009, 03:01 PM   #1
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,985
Exclamation Is it REBUILT or NEW - MAF from autopartsway.ca



I ordred a MAF sensor form Autopartsway.ca yesterday. Well the order came in this morning. I open the box and i see this beat up Bosch box and the sensor itself has different screws than the original safety torx. I called and asked if this is a rebuilt part, they say no.

Please see the pics and tell me what you think. I even wiped around the screws and it was dirty. I debating if i should send it back or just use it anyways. Part was $300.

Damn pics are huge, sorry.
Attached Images
File Type: jpg DSC03953.jpg (291.6 KB, 167 views)
File Type: jpg DSC03958.jpg (276.6 KB, 169 views)
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 03:10 PM   #2
Quack
Wheelman
 
Quack's Avatar
 
Join Date: Jul 2002
Location: Toronto
Posts: 12,081
Send a message via MSN to Quack
that looks used, the box has been retaped, and the electrical connector looks old & corroded, you got the shaft, I've replaced over a hundred MAF's and all the Bosch boxes are in mint shape with minimal tape, and the MAF sensor itself was very clean.
__________________

Maxbimmer Drama, You Gotta Love It
Quack is offline   Reply With Quote
Old 03-11-2009, 03:10 PM   #3
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,067
definately doesn't look new.
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 03-11-2009, 03:23 PM   #4
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,985
Damn it, that what i said too. Im calling them right now!
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 04:28 PM   #5
BSL
2nd Gear Member
 
BSL's Avatar
 
Join Date: May 2008
Location: ptbo
Posts: 210
Looks like you just got jammed
I hope they honour a return.

Maybe email them a link to this thread
BSL is offline   Reply With Quote
Old 03-11-2009, 04:34 PM   #6
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,985
I called and filed for a return. Now i gotta wait up to 72 hours to get some return number. And ofcourse im gonna have to pay for shipping.

The address on the box that it came in was 4915 Bathurst St #209 M2R 1X9 North York.
Hopefully i can bring it there.

Im even thinking of going there to see wtf and whytf they sent me this shit.
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 04:38 PM   #7
arsevader
4th Gear Member
 
Join Date: Oct 2005
Location: Toronto
Posts: 709
Definitely old. I bet some unscrupulous person sent their old MAF back as a return and it wasn't checked properly.
__________________


'85 325e
'90 325i
'02 325it
'03 320i
'15 M235i

'96 Volvo 850R
arsevader is offline   Reply With Quote
Old 03-11-2009, 04:41 PM   #8
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,985
Looking at the housing there are no sratches on the tabs where the clips go.

So im thinking its rebuilt. And look at those screws, OEM screws are safety torx
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 05:28 PM   #9
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
i would tell them your not going to pay for the return shipping. its their mistake. someone on their end didnt preform their job properly, you paid for a new one, and thats not what you got. you shouldnt have to pay for the companies mistake, they should take ful responsibility if they truly value thei customers.
__________________


flickr
craigIS is offline   Reply With Quote
Old 03-11-2009, 05:32 PM   #10
TNation
Banned
 
Join Date: Aug 2007
Location: Toronto/Calgary
Posts: 1,905
that's definitely not new! look at how worn the electrical connector is!
TNation is offline   Reply With Quote
Old 03-11-2009, 05:36 PM   #11
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,985
They have their damn Return Policy that states that the customer has to pay for returns.
But i will most definitely tell them to cover all the cost, since i paid for a new part.
Will also throw in that i will post on every forum about their parts that i got.
As mentioned will attach the link to this page so they see whats good.
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 11:23 PM   #12
Miguel
...Delt Smash
 
Miguel's Avatar
 
Join Date: Oct 2002
Location: Dudebridge
Posts: 10,879
If you paid with Visa, threaten to file a claim... you'll get your money back.
__________________
Miguel is offline   Reply With Quote
Old 03-12-2009, 10:36 AM   #13
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
Quote:
Originally Posted by Dado 540 View Post
They have their damn Return Policy that states that the customer has to pay for returns.
But i will most definitely tell them to cover all the cost, since i paid for a new part.
Will also throw in that i will post on every forum about their parts that i got.
As mentioned will attach the link to this page so they see whats good.
I have been in customer service for years, and have never heard of a customer having to pay for something to be returned. you paid for something new, and thats what you should get. its not like you paid new part price to have a used part sent, so you can spend more money to return the used part at cost to you! if you used visa, you can tell them your putting in a claim, and if that doesnt work, then put in a claim. if they want to be assholes im sure you can be one right back. all thats fair is fair.
__________________


flickr
craigIS is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:44 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018