Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Misc > Off-topic
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-01-2009, 08:04 PM   #1
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
Not a BMW problem but..



I know many here have different SUVs so I'll ask you guys.

This is for my 04 Lincoln Navigator

Today while driving on the highway I've noticed that there was lack of power at WOT and it seemed like something was cutting the power (car was almost jerking), but when speeding up slowly everything was fine.

I tried the same from a stop light, if accelerating "normally" everything was fine but if I pushed the gas pedal down there was hesitation..then later check engine light came on.

I had similar problems with a few different cars before and it was always spar plugs/cables..does this sound like same problem?

PS. I was lucky enough to not have any problems (knock on the wood) with the 545 yet, 36,000km since I bought it
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-02-2009, 10:21 AM   #2
dtthiaga
6th Gear Member
 
Join Date: Mar 2002
Location: Ontario
Posts: 1,552
Mass Air Flow Sensor?

I've had them go on few GM vehicles with similar results.
Pull the Error codes and see.
dtthiaga is offline   Reply With Quote
Old 03-02-2009, 10:29 AM   #3
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
Quote:
Originally Posted by dtthiaga View Post
Mass Air Flow Sensor?

I've had them go on few GM vehicles with similar results.
Pull the Error codes and see.
That's what a few others told me last night, I'll have tog et some of that electric contact cleaner and clean it..
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-02-2009, 10:51 AM   #4
bmwm5lover
is BMW crazy
 
bmwm5lover's Avatar
 
Join Date: Sep 2002
Location: Thornhill
Posts: 15,454
Could also be a throttle Position Sensor.
__________________
www.enthusiastauto.caNeed a car???

His--'00 BMW ///M5 .:Jet BLK/BLK:.Individual-Style 65 Wheels; 9.5" Square Set up;275 Tires;Spacers;Black Kidneys;Muffler Delete; 3.5" Dual Tips; Beast Power; "Dinan" Ducts; E60 SSK; BC Coils
Hers--'07 BMW M5/6.:Indianapolis Red/Black:.
Toys
'88 BMW 635CSi
'81 MB 500 SEC Koenig
bmwm5lover is offline   Reply With Quote
Old 03-11-2009, 11:37 AM   #5
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
It was MAF, now I need to supercharge this beast and it'll be great
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-11-2009, 04:33 PM   #6
dtthiaga
6th Gear Member
 
Join Date: Mar 2002
Location: Ontario
Posts: 1,552
How much did it cost you?
Where did you get it fixed?
dtthiaga is offline   Reply With Quote
Old 03-11-2009, 05:02 PM   #7
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
Dealer sensor is $350 (not even close to $650 I paid for MAF for 540 last year), but I got it for $200..changed it myself.
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-11-2009, 05:12 PM   #8
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,974
I just got my MAf for the 540i from autopartsway and they sent me some used rebuilt shit and i paid $300. pretty pissed.
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 05:15 PM   #9
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
Quote:
Originally Posted by Dado 540 View Post
I just got my MAf for the 540i from autopartsway and they sent me some used rebuilt shit and i paid $300. pretty pissed.
Dealer charges $650, but if the one you got has 1 year warranty then it's ok, MAF is very simple and rebuilt ones are 99% new.
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-11-2009, 05:22 PM   #10
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,974
Did you see the pics i posted? You see it and tell me what you think?

http://www.maxbimmer.com/forums/showthread.php?t=117283
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 05:43 PM   #11
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
Did you buy it as NEW or Rebuilt?

Take a pic of the actual MAF sensor (inside). That's the part they rebuild, that outer "shell" is just that - a shell. In my Navigator you can take out the sensor so that's what they sell, not the whole "tube".
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-11-2009, 05:51 PM   #12
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,974
I cant even take the sensor cause those damn screws are not safety torx that are used on the MAF. On the site it doesnt state that it had a reduilt title. And when i called them they looked it up and told me that it was new.
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 06:11 PM   #13
Redster
Stuck In The 6th Gear
 
Redster's Avatar
 
Join Date: Mar 2006
Location: Kitchener
Posts: 3,623
If you bought it as rebuilt than that's what they sent you.

As far as I remember in the 540i MAF the sensor itself is fixed to the housing, can't be take out..

Did you install it and it doesn't work?

You could've also tried cleaning your old one with electric contact cleaner.
__________________
"You wanna make moves on the streets? Do not have any attachments, do not have anything in your life you are not willing to walk out on in 30 seconds flat if you spot the heat around the corner."
Redster is offline   Reply With Quote
Old 03-11-2009, 07:14 PM   #14
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,974
In 540i you can actually remove the sensor itself. Its got two safety torx screws holding it in place. Ive tried cleaning it, but the code jsut keeps popping up.

I haven't even tried installing the one they sent me, cause i wanted a new one and paid $300 for it. Just gonna return it, and look elsewere.
__________________
E39 540i Sport
Dado 540 is offline   Reply With Quote
Old 03-11-2009, 08:54 PM   #15
TNation
Banned
 
Join Date: Aug 2007
Location: Toronto/Calgary
Posts: 1,908
Quote:
Originally Posted by Dado 540 View Post
In 540i you can actually remove the sensor itself. Its got two safety torx screws holding it in place. Ive tried cleaning it, but the code jsut keeps popping up.

I haven't even tried installing the one they sent me, cause i wanted a new one and paid $300 for it. Just gonna return it, and look elsewere.
You can get a way better deal on ebay.
http://cgi.ebay.ca/New-BMW-Air-Mass-...3A1|240%3A1318
TNation is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015