Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-17-2011, 06:36 PM   #16
DIY
Permanently Dirty
 
DIY's Avatar
 
Join Date: Aug 2010
Location: Etobicoke
Posts: 528
Quote:
Originally Posted by bme30 View Post
what is a good brand of ball joints to get?

Keep in mind i plan on some autox and might it up a road course or two
+1.
DIY is online now   Reply With Quote
Old 09-18-2011, 01:21 PM   #17
craz azn
6th Gear Member
 
craz azn's Avatar
 
Join Date: Feb 2004
Location: Port Perry
Posts: 7,498
Send a message via MSN to craz azn
Lemforder is what I had in my car, never was a problem for me. I tried Meyles once, they didn't have the same travel as the Lemforders did.
__________________

Rippin' Proper | Youtube | Vimeo |
craz azn is offline   Reply With Quote
Old 09-18-2011, 03:37 PM   #18
DIY
Permanently Dirty
 
DIY's Avatar
 
Join Date: Aug 2010
Location: Etobicoke
Posts: 528
Just so I'm sure, what's an indication that the problems the ball joint?

My steering wheel shakes back and fourth from 70 to 120, at first I thought it might be a bearing, but there's no noise and the hub doesn't seem to be loose... Could it be the balljoint? (I've also gone through balancing and allignment twice, both at different places ...)

I was told by my cousin that ball joints could be the problem, any thoughts?
DIY is online now   Reply With Quote
Old 09-18-2011, 08:01 PM   #19
BMe30
all by chance...
 
BMe30's Avatar
 
Join Date: Mar 2008
Location: mississauga
Posts: 819
Holy crap... I posted this 2 years ago lmao
__________________

Gone but not forgotten
BMe30 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:02 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.