Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-21-2008, 04:49 PM   #1
nikijack
2nd Gear Member
 
Join Date: Jul 2003
Location: Markdale
Posts: 61
Send a message via MSN to nikijack Send a message via Yahoo to nikijack
broken spring

Hi everybody:
I just broke a front spring on my e39. In the past month, I've replaced two front wishbones, one front wheel bearing, two front shocks (replaced Bilstein with Koni FSD) and then the spring broke and destroyed the new tire. Now the car is out of action, waiting for the springs and tire to arrive. And slow delivery at Christmas time.

cheers,

Jack
nikijack is offline   Reply With Quote
Old 12-21-2008, 05:17 PM   #2
MLue1
3rd Gear Member
 
MLue1's Avatar
 
Join Date: May 2008
Location: Markham
Posts: 451
Quote:
Originally Posted by nikijack View Post
Hi everybody:
I just broke a front spring on my e39. In the past month, I've replaced two front wishbones, one front wheel bearing, two front shocks (replaced Bilstein with Koni FSD) and then the spring broke and destroyed the new tire. Now the car is out of action, waiting for the springs and tire to arrive. And slow delivery at Christmas time.
Sorry to hear Jack, were these the original BMW spring that broke?
__________________
Mark
'99 E39 540iT
MLue1 is offline   Reply With Quote
Old 12-21-2008, 05:27 PM   #3
MiroE36
6th Gear Member
 
MiroE36's Avatar
 
Join Date: Nov 2008
Location: Toronto
Posts: 1,896
that sucks man... hope your up and running soon
__________________
1992 325i / Briliant rot - SOLD @ 301,000km
1998 318is / Arktic silber - SOLD @ 207,000km
2007 335i / Jet Black - CURRENT @ 28,000 km

MiroE36 is offline   Reply With Quote
Old 12-21-2008, 08:22 PM   #4
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,972
What caused it to break, just broke out of the blue or did you hit something hard?
Dado 540 is offline   Reply With Quote
Old 12-21-2008, 09:08 PM   #5
nikijack
2nd Gear Member
 
Join Date: Jul 2003
Location: Markdale
Posts: 61
Send a message via MSN to nikijack Send a message via Yahoo to nikijack
Hi:
My Bilsteins were shot after 150,000 k, completely seized, and put huge stress on the other components. I changed to Koni FSD, the car felt great on the first ride. On the second ride the spring broke. I've ordered Eibach Proline, and a new tire. Just another expensive month.

Jack
nikijack is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.