Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-24-2008, 08:19 AM   #1
rude_lankan
1st Gear Newbie
 
Join Date: Jan 2007
Location: Markham
Posts: 40
oil light?

hey i heard the oil sensor for the e46 are a common problem! i top it off with some oil then after a few days the oil lights comes yellow again..anyone have this problem and get it fixed? Will the oil sensor fix do?

thanks
rude_lankan is offline   Reply With Quote
Old 10-24-2008, 09:32 AM   #2
King Luis
The King.
 
King Luis's Avatar
 
Join Date: May 2003
Location: Milton
Posts: 7,377
Send a message via MSN to King Luis
have you done a complete oil change? is the dipstick saying that enough oil is in there?
maybe the oil sensor is the problem if you answered yes.
__________________
Incoming:2013 Candy White VW Golf TDI
Mods: TBD.

Sold:2004 Silver Gray M3
Mods: Dice Unit, EAS Angel Eyes, Painted Reflectors, CSL Diffuser, Smoked Corners, PSS10s, 15mm Front and 10mm Rear Spacers.

Gone:1990 Brilliantrot 325is
Mods: Alpine speakers and HU, Euro Projectors, Magnaflow Muffler, Euro Smoked Tails and GC Coilovers.
King Luis is offline   Reply With Quote
Old 10-25-2008, 01:13 PM   #3
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,706
common problem on the e46's needs a sensor if oil level is good
BmW1819 is online now   Reply With Quote
Old 10-26-2008, 01:01 AM   #4
Mikeee46coup
6th Gear Member
 
Join Date: Feb 2005
Location: Waterloo/Mississauga
Posts: 1,405
My 323ci oil pan sensor died years ago (around 90,000km), easy DIY while doing an oil change, the part was around $120 (from Crevier, pretty sure Tischer will have it cheaper nowadays) the design has been updated, the car now has 228,000km the sensor is still works.
__________________

DPE Wheels, H&R Cupkit, M3 Interior...too many mods to list.
Mikeee46coup is offline   Reply With Quote
Old 10-26-2008, 08:48 AM   #5
piotrek636
formerly Lucky
 
piotrek636's Avatar
 
Join Date: Dec 2002
Location: Mississauga
Posts: 623
wtf, half a dozen e46 problems on top of the forum once the cold weather hits ? whats going on ?
piotrek636 is offline   Reply With Quote
Old 10-26-2008, 09:32 AM   #6
rude_lankan
1st Gear Newbie
 
Join Date: Jan 2007
Location: Markham
Posts: 40
have you guys heard of the e46's burning oil? and how its common?
rude_lankan is offline   Reply With Quote
Old 10-26-2008, 06:20 PM   #7
dulak
2nd Gear Member
 
Join Date: Nov 2007
Location: Mississauga
Posts: 74
I have never heard of BMW's burning oil as a common problem.

rude_lankan are you part of TPC and owned a prelude?

Its not like an H22 You're oil level sensor is probably shot, had the same problem and that is a common part that fails. The new sensors are updated as Mike mentioned.

Changed the sensor while doing my oil change and problem went away.
dulak is offline   Reply With Quote
Old 10-26-2008, 06:30 PM   #8
Mikeee46coup
6th Gear Member
 
Join Date: Feb 2005
Location: Waterloo/Mississauga
Posts: 1,405
Quote:
Originally Posted by Lucky View Post
wtf, half a dozen e46 problems on top of the forum once the cold weather hits ? whats going on ?
They get fussy when the weather changes, mine threw a speed sensor light for a few minutes last week for no reason I could find, every spring when things thaw I'll get one or two flashes of the SRS light, never a code thrown though, the light i'll just flicker once or twice!

Gives the car charater I guess. Overall great car, far fewer bugs than my previous and current MB's which are frequently in "Christmas tree mode"

...too many sensors.
__________________

DPE Wheels, H&R Cupkit, M3 Interior...too many mods to list.
Mikeee46coup is offline   Reply With Quote
Old 10-26-2008, 08:29 PM   #9
rude_lankan
1st Gear Newbie
 
Join Date: Jan 2007
Location: Markham
Posts: 40
can i get the sensor at the bmw dealership thats already updated? or is there another store that i have to go get it at?...cuz mine comes on here and there...when i put oil in it goes away for a few days and then back again. yellow coloured though, not red!
rude_lankan is offline   Reply With Quote
Old 10-30-2008, 05:48 PM   #10
Airbalancer
2nd Gear Member
 
Join Date: May 2005
Location: Cobourg Ontario
Posts: 149
My sensor has been gone for awhile, turn the car on , it comes on then goes off.
Never had to top the oil
Can not be bothered to change the sensor
Airbalancer is offline   Reply With Quote
Old 02-09-2009, 07:58 PM   #11
01330ci
2nd Gear Member
 
Join Date: Feb 2009
Location: scarborough
Posts: 120
Cool

same goes for mine but sometimes other stuff lights up and goes away like my battery or the rear bulbs being burnt but it dissapears afterwards

Quote:
Originally Posted by Airbalancer View Post
My sensor has been gone for awhile, turn the car on , it comes on then goes off.
Never had to top the oil
Can not be bothered to change the sensor
01330ci is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.