Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-27-2008, 08:29 AM   #1
frankzen
2nd Gear Member
 
frankzen's Avatar
 
Join Date: Aug 2004
Location: Montreal's Glorious West Island
Posts: 156
Question Stalling problem

Just had the MAF replaced on my '95 318i to cure a SES light (the guys found a used but good one for $200!!) and the O2 sensor was replaced to cure a burning-a-lot-of-gas problem. BUT the car still stalls when first started up unless I goose the accelerator a couple of times after it starts. Anybody have any idea what the problem is now?
__________________
-----
--'95 318i--
frankzen is offline   Reply With Quote
Old 06-27-2008, 10:18 AM   #2
98Dinan3
6th Gear Member
 
98Dinan3's Avatar
 
Join Date: Jun 2005
Location: Hamilton
Posts: 2,585
Send a message via MSN to 98Dinan3
I'd be willing to bet it's a dirty/faulty ICV. (idle control valve) It causes a dipping or jumping of the idle when it's not functioning properly... mine does the same thing, but only from time to time...
__________________
98Dinan3 is offline   Reply With Quote
Old 06-27-2008, 10:39 AM   #3
5JABIJ8
5th Gear Member
 
5JABIJ8's Avatar
 
Join Date: Feb 2007
Location: GTA
Posts: 981
Quote:
Originally Posted by 98Dinan3 View Post
I'd be willing to bet it's a dirty/faulty ICV. (idle control valve) It causes a dipping or jumping of the idle when it's not functioning properly... mine does the same thing, but only from time to time...
I have this problem but I usually just rev it a couple times and it usually solves it self. But I would like to get around to working on cleaning the ICV.. and idea's what would be the best way to do this?... is there DIY link for this?
__________________
(OO==[][]==OO)
5JABIJ8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:06 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.