Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Multimedia > Videos and Sound
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Old 06-12-2008, 12:32 AM   #16
♠ ♠ ♠
AceOfSpades's Avatar
Join Date: Aug 2006
Location: Creston, Iowa
Posts: 4,170

girls are evil, as soon as she opens her mouth...disaster!
AceOfSpades is offline   Reply With Quote
Old 06-12-2008, 03:45 AM   #17
Join Date: Mar 2007
Location: Brampton
Posts: 2,190
Send a message via MSN to ZHP_Bimmer05
sounds like hes pressing the brakes too hard before entering the turn, then the ABS kicked in, and locked up the wheels, then it went haywire anfter that

2004 Mazda RX8 GT: 6spd VR
ZHP_Bimmer05 is offline   Reply With Quote
Old 06-12-2008, 09:11 PM   #18
2nd Gear Member
Join Date: Sep 2006
Location: Toronto
Posts: 280

Read back what u wrote?

ABS LOCKED up the brakes!?

no, classic thing everyone does...u try to turn the wheel further, its instinkt

he was carrying way too much speed...only thing i can think he could have done is try to power oversteer...

- 1994 530iT: M60B40'd + 5spd conversion, 18" Style 32's, Magnaflow catback, Voltglands, angel eyes, Erebuni ACS body kit, 10" sub and amp, Alpine deck, soon to be supercharged!!

- 1984 635CSI: 92 535 M30 5spd, Koni Yellows, Eibachs, Magnaflow cat + catback, short throw shifter, Style 5's, 2x 10" subs, soon to have 3.46LSD. STOLEN! baby's gone.
Red_Liner740 is online now   Reply With Quote
Old 06-18-2008, 07:55 PM   #19
Trinational 951
DAM's Avatar
Join Date: Jun 2002
Location: the M5V
Posts: 2,963
Airbags didn't deploy, damage couldn't be that bad
You drive to work? I work to drive.
DAM is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 01:37 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015