Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-02-2008, 01:31 AM   #1
nyt
1st Gear Newbie
 
Join Date: Feb 2006
Location: toronto
Posts: 37
Can't feel the Bass on my E39 although set to max

The bass on my E39 is not loud even when the bass is set to max. When I increase the volume, the audio is very clear and loud but I don't get the heart bumping feeling you get when the bass is set to the max on other cars. I have been into other E39s and they were bumping when there base was set to max. I donít think the problem is with my speaker since my speakers work fine. I was wondering if any one knows what I need to do to get base on my car. Is there anything on the amp that I need to thick to get the bass?

Thanks
nyt is offline   Reply With Quote
Old 06-02-2008, 01:47 AM   #2
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,032
you need a subwoofer. e39's do not have them stock.
Boots R is offline   Reply With Quote
Old 06-02-2008, 04:26 AM   #3
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,972
i have the same problem on my E39....i thought they came with 2 woofers in a plastic enclosure right under your rear window. i think they are Nokia woofers. My Nissan is stock and it sounds like two 10'' in the back when bass is set to high, i cant believe they wouldnt put a woofer in a bimmer. originally when i got the car the guy had a system in the trunk and he took it out, so i thought that he did something to the stock amp.
Dado 540 is offline   Reply With Quote
Old 06-02-2008, 09:03 AM   #4
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
Quote:
Originally Posted by Boots R View Post
you need a subwoofer. e39's do not have them stock.
well, that depends on what E39 you have
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 06-02-2008, 09:42 AM   #5
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,032
Quote:
Originally Posted by Gamite View Post
well, that depends on what E39 you have
whoops, should have said NON-M5.



Speaking of which, why don't you buy an m5 subwoofer and install it?

http://cgi.ebay.com/ebaymotors/_Car-...em14023803060&


OEM ftw.
Boots R is offline   Reply With Quote
Old 06-02-2008, 09:54 AM   #6
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
The M Audio subs are bigger than the ones boots posted. They're better, however, nothing beats aftermarket. I'm not entirely satisfied with their performance, but they'll have to do for now.
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 06-02-2008, 10:28 AM   #7
Kal
maxRealtor
 
Join Date: Jul 2002
Location: Brampton, Ontario
Posts: 3,756
Send a message via MSN to Kal
the e39 sound system is shit
Kal is offline   Reply With Quote
Old 06-02-2008, 10:33 AM   #8
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
most bmw sound systems are shit.
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 06-02-2008, 11:22 AM   #9
Quack
Wheelman
 
Quack's Avatar
 
Join Date: Jul 2002
Location: Toronto
Posts: 12,062
Send a message via MSN to Quack
I have a 98 540i, I have a factory sub under the rear deck, I guess you guys don't have the upgraded sound system from the factory.
__________________

Maxbimmer Drama, You Gotta Love It
Quack is offline   Reply With Quote
Old 06-02-2008, 11:31 AM   #10
europrince
6th Gear Member
 
Join Date: Feb 2006
Location: North York
Posts: 6,729
^ Those BMW sound systems are made to give you crisp vocals in jazz and pop, crisp instrumental in classical music. They are not made for base thumping dance music. How many owners of a NEW 5 series do you hear pounding electronica or hip hop from a block away?
europrince is offline   Reply With Quote
Old 06-02-2008, 11:59 AM   #11
chromius
6th Gear Member
 
chromius's Avatar
 
Join Date: Dec 2002
Location: Ottawa
Posts: 4,006
Quote:
Originally Posted by Boots R View Post
whoops, should have said NON-M5.



Speaking of which, why don't you buy an m5 subwoofer and install it?

http://cgi.ebay.com/ebaymotors/_Car-...em14023803060&


OEM ftw.
Some Non-M5 e39's had them too depending on what options you had.
__________________
Photobucket
chromius is offline   Reply With Quote
Old 06-02-2008, 12:17 PM   #12
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
In my experience, I disconnected the factory subs and installed two 12" subs and an amp. With the rear seat down it sounded great, but with the seat up, I barely heard it. I felt it, but didn't hear it very much. Chromius mentioned last time I saw him that the rear of the e39 is riddled with sound absorption material, so that would make sense!
__________________
everlast is offline   Reply With Quote
Old 06-02-2008, 04:41 PM   #13
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,972
Quote:
Originally Posted by Boots R View Post
whoops, should have said NON-M5.



Speaking of which, why don't you buy an m5 subwoofer and install it?

http://cgi.ebay.com/ebaymotors/_Car-...em14023803060&


OEM ftw.
Mine is a 1998...this 2000 M5 Woofer system should be a plug in, in the 98's?

and if it did fit as a plug in, i would have to change the amp as well....right?
Dado 540 is offline   Reply With Quote
Old 06-02-2008, 04:44 PM   #14
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
Do you have the factory subs or not? DSP?
__________________
everlast is offline   Reply With Quote
Old 06-02-2008, 04:58 PM   #15
uniter
spook
 
Join Date: May 2008
Location: Waterloo, ON
Posts: 21
DSP Subs are alright man, I get pretty good bass from them There's a good reason you can't hear them from the outside of the car, the 5's are built for isolation.
__________________
Dinan ECU/CAI/Air Mass Meter. Rogue Engineering Clutch & Flywheel (First and Only), SSK, CDV delete. SuperSprint Exhaust, Resonator delete. F/R Eibach Sways. CF Hood
uniter is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.