Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-20-2019, 07:34 PM   #1
jsonli
1st Gear Newbie
 
Join Date: Nov 2007
Location: Toronto
Posts: 28
DSC and Brake Light on after alignment



I recently had an alignment done at the Altech in Etobicoke cause the car seemed to be handily pretty sloppy.

Guy said my alignment was pretty out of whack, and that my tie rods were seized. He'd torch it to heat them up and loosen it to get the alignment as close to spec as possible.

He did it, and the car drives a lot better now (although steering wheel is still not straight, off by 5-10 degrees), but the DSC and brake light came on the day after, and still has not gone off after 500km of driving.

Could the shop maybe have messed something up?
Or is just a matter of waiting longer for the computer to adapt to the newer alignment? Can I reset anything? I've tried pulling the battery.
Attached Images
File Type: jpg IMG_3412.jpg (315.3 KB, 18 views)
jsonli is offline   Reply With Quote
Old 09-23-2019, 12:13 AM   #2
jabela
6th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 1,309
Quote:
Originally Posted by jsonli View Post
I recently had an alignment done at the Altech in Etobicoke cause the car seemed to be handily pretty sloppy.

Guy said my alignment was pretty out of whack, and that my tie rods were seized. He'd torch it to heat them up and loosen it to get the alignment as close to spec as possible.

He did it, and the car drives a lot better now (although steering wheel is still not straight, off by 5-10 degrees), but the DSC and brake light came on the day after, and still has not gone off after 500km of driving.

Could the shop maybe have messed something up?
Or is just a matter of waiting longer for the computer to adapt to the newer alignment? Can I reset anything? I've tried pulling the battery.
Is the handbrake fully released?
Otherwise it sounds like an ABS sensor is damaged. Make sure they're plugged in properly and look for damage, especially melting or something.
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.maisonapothecare.ca
jabela is offline   Reply With Quote
Old 09-29-2019, 10:35 AM   #3
Espritv8
2nd Gear Member
 
Espritv8's Avatar
 
Join Date: Sep 2011
Location: Montreal, QC
Posts: 102
I don't think an alignment would affect your ABS DSC unit in any way.

He most likely damaged one of the ABS sensors. That's the only thing I can think of.
Espritv8 is offline   Reply With Quote
Old 09-30-2019, 10:00 AM   #4
jsonli
1st Gear Newbie
 
Join Date: Nov 2007
Location: Toronto
Posts: 28
It was fixed by straightening the steering wheel, and also a recalibration of the steering angle sensor.

Basically, the DSC system needs to know what angle your wheels are pointed at accurately in order to determine when your car is sliding and when it isn't.

My alignment was pretty bad before, so the inputs were so different compared to before that the system was confused and refused to work.
jsonli is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:12 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018