Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-10-2018, 10:25 PM   #1
Raptorz
1st Gear Newbie
 
Join Date: Nov 2017
Location: Toronto
Posts: 2
Bi-Xenon headlight issue - someone help!!



Hey guys, I?ve been a constant lurker on this site but have never actually made a post until today. Usually I am able to siphon through all of the posts to come to an answer when I?m having issues BUT I can?t come to answer to this.

A little back story..
I drive a 04? 330ci - 6 speed manual..
the owner before me had a collision on the driver side front fender which affected the driver headlight. When buying the car they told me I just had to replace the headlight (a bi-xenon self adaptive headlight)

Fast forward to today.. I bought another e46 325ci as a parts car. It has bi-xenon headlights as well but non adaptive but they worked totally fine on the that car.

I exchanged the the headlights from the parts car to my own car.. didn?t work
After about an hour of investigation I couldn?t figure out what was wrong.. I had a hunch there was something wrong with the wiring harness on my car but there wasn?t.

So while my car was turned on and the driver side headlight was connected and not working, I disconnected the passenger side headlight and after about 3 seconds voila! The driver side headlight worked.. I reconnected the passenger side headlight and both headlights were on and working well.. when I sat in my car I still had the ?headlight out? warning on my dash. I turned my car off and on like 5 times. It was still working and still had the warning light on my dash but I was thinking. I?ll just live with the warning on the dash.

About 20 minutes later I went to go out somewhere and the light headlight stopped working.. so I repeated the process I went thru. Disconnecting my passenger side headlight and waiting and it turned back on. And I drove and after it turned it off for about 30 minutes it stopped working again.

I?m really confused with what?s going on.. is it because my car calls for adaptive xenon lights? Is there a short somewhere? Is it my LCM, should I put the one from my parts car?

If anyone has any information that?ll be able to help me, please let me know.. appreciate you guys taking your time out to read this. Sorry if it?s a little long just wanted to cover all the details.
Raptorz is offline   Reply With Quote
Old 02-11-2018, 08:44 PM   #2
jabela
6th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 1,265
Maybe you need to do some coding to deactivate the adaptive feature. Did you also install the non-adaptive light on both sides of your car? I'd try that first.
If you need to do some coding, look at getting the custom OBDII cable and the INPA software. You should be able to find help for that on E46fanatics.com
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.maisonapothecare.ca
jabela is offline   Reply With Quote
Reply

Tags
bi-xenon, headlights, xenon

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:20 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018