Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-14-2016, 10:52 AM   #1
roachy666
1st Gear Newbie
 
Join Date: May 2016
Location: Toronto
Posts: 22
MAF Question



Hey Guys,

I recently bought an 02 bmw 320i used. The idle was a little rough so I changed the air filter and cleaner the MAF with a q-tip. Since Im an idiot, I broke one of the filaments on the MAF (ouch). I bought a replacement on ebay, installed it and now I am getting p0171 and p0174 codes. My scanner tells me at idle MAF is reading 3.5 g/s which is normal. I have just put in a new rad cleared codes and havent driven it really before this happen so it IS possible I had the p0171 and p0174 before. It is not idling rough and the acceleration seems fine but again I have not much to compare it too since I basically only drove it 3 min from where I bought it to my house. Can anyone give me some guidance on a way to diagnose if the MAF I bought is defective before I complain to the part supplier? Thanks in advance!
roachy666 is offline   Reply With Quote
Old 06-14-2016, 11:03 AM   #2
Blackedout95
6th Gear Member
 
Join Date: Feb 2009
Location: Canada
Posts: 1,404
3.5 g/s is good, simply clear codes and drive it, see if it returns, go from there. Sometimes it isn't the MAF itself and rather the plug, inspect the wiring but if it's reading ok it is likely ok

If it still idles rough start with the very basics, do you have a crack/leak in the boots after the MAF?
__________________
E46
Blackedout95 is offline   Reply With Quote
Old 06-14-2016, 11:15 AM   #3
roachy666
1st Gear Newbie
 
Join Date: May 2016
Location: Toronto
Posts: 22
Maf Question

Im going to take it apart tonight and inspect all the intakes boots as I hear they are prone to cracking...thanks for the input
roachy666 is offline   Reply With Quote
Old 06-14-2016, 03:51 PM   #4
doogee
6th Gear Member
 
doogee's Avatar
 
Join Date: Jun 2007
Location: Ancaster
Posts: 3,543
Send a message via MSN to doogee
You have a vacuum leak.
__________________


Dakar M3 Track Build Thread
doogee is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2017