Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-26-2003, 08:50 PM   #1
Fernando
2nd Gear Member
 
Fernando's Avatar
 
Join Date: Feb 2003
Location: King City
Posts: 266
pixels missing in instrument cluster



Has anyone experienced this?

If so, was it out of warranty and how was it handled.

This is very common on the e34 and e39 5ers, and I'm currently going through this.

Stealer (read dealer) said it's $800 + labour. Regardless, I'll have to get them to re-program my mileage back into car once it's installed.

Even if I do it myself...

I've researched the cause to be poorly soldered contacts behind the dash...

Lawyer in States in attempting a class action suit, but needs more support in the way of letters sent to Bmw.
__________________
"I told you a million times, I hate it when you exaggerate !"
Fernando is offline   Reply With Quote
Old 02-26-2003, 10:15 PM   #2
WASABI
OG
 
Join Date: Mar 2002
Location: Mavis
Posts: 3,221
I thought it's covered in the certified series warranty. Check your pamphlet but am pretty sure it is. Someone on this board mentioned their's froze one time and it was replaced under warranty.
WASABI is offline   Reply With Quote
Old 02-26-2003, 10:50 PM   #3
mkgino
6th Gear Member
 
Join Date: Apr 2002
Location: Toronto
Posts: 7,719
Yup it should be covered under certified series. My OBC had a strip missing and I got it replaced for the $50 deductable. It would have been like $200
mkgino is online now   Reply With Quote
Old 02-27-2003, 12:07 AM   #4
BeemerBuddy
2nd Gear Member
 
Join Date: Sep 2002
Location: victoria bc
Posts: 205
MKgino lol ur sig is funking hilarious, also mkgino "man-whore" lol. Ill check at work for ya to if its covered under warranty for ya i need to know your year and milage.
BeemerBuddy is offline   Reply With Quote
Old 03-31-2003, 09:43 AM   #5
Fernando
2nd Gear Member
 
Fernando's Avatar
 
Join Date: Feb 2003
Location: King City
Posts: 266
Missing Pixels problem

Quote:
Originally posted by BeemerBuddy
MKgino lol ur sig is funking hilarious, also mkgino "man-whore" lol. Ill check at work for ya to if its covered under warranty for ya i need to know your year and milage.

My car is a '99 540 w/ 119,400 km, NOT cpo.

Do you know anyone who got this fixed by BMW where they picked up the tab, as this is a known defect?


Thanks in advance

Fern
__________________
"I told you a million times, I hate it when you exaggerate !"
Fernando is offline   Reply With Quote
Old 03-31-2003, 12:44 PM   #6
WASABI
OG
 
Join Date: Mar 2002
Location: Mavis
Posts: 3,221
Certified series is warrantied up to 120K. What do you mean by not CPO?
WASABI is offline   Reply With Quote
Old 03-31-2003, 02:21 PM   #7
Fernando
2nd Gear Member
 
Fernando's Avatar
 
Join Date: Feb 2003
Location: King City
Posts: 266
Not cpo

Car was not purchased at bmw dealership.

Was purchased at private dealership, shortly after he purchased it from bmw canada auction (off lease).

CPO only applies when you purchase car through dealership (which gives the cpo warranty)... Not all Bimmers at bimmer dealers are cpo cars.

Did the research and cpo cars were $3500-$5000 more.

I know what your going to say now, "use the money you saved to get the cluster fixed."

Question remains :" has anyone had this done out of warranty?"

Thanks in advance,

Fern
__________________
"I told you a million times, I hate it when you exaggerate !"
Fernando is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:15 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018