Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-18-2019, 10:16 PM   #1
timel3ss_t
1st Gear Newbie
 
Join Date: Jan 2019
Location: Mississauga, Canada
Posts: 1
Battery issue. Always needs a boost!



Brand new battery was installed. My issue is that the car would not start unless you give it a boost and it will run until I turn off the car again. Someone please help before I bring it to the mechanic.
timel3ss_t is offline   Reply With Quote
Old 01-19-2019, 11:01 PM   #2
jabela
6th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 1,305
Simple, test the battery with a multimeter with the car running and with the car off.
If you have a recent X5, make sure the battery is "registered" with the car.
Get an intelligent charger and make sure the battery is actually charged. You know what level it was when you bought it.
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.maisonapothecare.ca
jabela is offline   Reply With Quote
Old 01-24-2019, 10:01 AM   #3
Dinanstu
4th Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 619
A failing starter could also be a fault.
Load test the battery, even new, it could have a bad cell.
Dinanstu is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018