Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-11-2003, 04:22 PM   #1
King Luis
The King.
 
King Luis's Avatar
 
Join Date: May 2003
Location: Milton
Posts: 7,363
Send a message via MSN to King Luis
whats wrong??????



i was driving on the highway today and all of a sudden the revs die and the check engine light comes on. then the oil light turns on. i pull over immedietly and check every thing.
-no leaks
-enough gas
-oil temp was fine
-oil condition and level fine
-gas reaches injectors
-when tried start but would not turn over
-no burnt smell
-battery works
what can it be????????
my brother says electrical but that gives no reason for the oil light to come on.
i can't think of anything else. except for oil pump failure but why wouldn't the engine start or try to turn over??
can you guys help????
the car is a 96 dodge stratus, 5spd, 2.0L
__________________
Current:2013 Candy White VW Golf TDI
Mods: TBD.

Sold:2004 Silver Gray M3
Mods: Dice Unit, EAS Angel Eyes, Painted Reflectors, CSL Diffuser, Smoked Corners, PSS10s, 15mm Front and 10mm Rear Spacers.

Gone:1990 Brilliantrot 325is
Mods: Alpine speakers and HU, Euro Projectors, Magnaflow Muffler, Euro Smoked Tails and GC Coilovers.
King Luis is offline   Reply With Quote
Old 09-12-2003, 01:58 AM   #2
nzer
4th Gear Member
 
nzer's Avatar
 
Join Date: Jan 2003
Location: Auckland, New Zealand
Posts: 674
I would be checking you have a spark and everything now.
__________________
BMWs Downunder
http://www.bimmersport.co.nz
nzer is offline   Reply With Quote
Old 09-12-2003, 05:22 PM   #3
King Luis
The King.
 
King Luis's Avatar
 
Join Date: May 2003
Location: Milton
Posts: 7,363
Send a message via MSN to King Luis
i just got a call from the dealer and:
timing belt went(220,000km later) and i have bent valves
__________________
Current:2013 Candy White VW Golf TDI
Mods: TBD.

Sold:2004 Silver Gray M3
Mods: Dice Unit, EAS Angel Eyes, Painted Reflectors, CSL Diffuser, Smoked Corners, PSS10s, 15mm Front and 10mm Rear Spacers.

Gone:1990 Brilliantrot 325is
Mods: Alpine speakers and HU, Euro Projectors, Magnaflow Muffler, Euro Smoked Tails and GC Coilovers.
King Luis is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:05 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2017