Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 1/2/4 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-19-2019, 10:32 PM   #1
BeamerKujo
1st Gear Newbie
 
Join Date: Nov 2019
Location: Canada
Posts: 1
Possibly blown engine??



Hey guys need some advice, not criticism for my stupidity as I was in a tight situation.

Long story short I was about a 20 minute drive (21km) when my car started to overheat due to a rad hose that blew off, I put the water I had in my car in the reservoir which wasn't enough so I got rad fluid from a stranger, rigged it up and drove home but it continued overheating the entire way (I needed to get home and have no way to budget a tow truck to pick it up) and by the time I got into my town and stopped at a red light it quit on me and wouldn't start, after I let it cool off and brought it home it sounded rough until I filled up the rad but it still overheats, what damage have I done and is it worth repairing? I should mention it an 01 325i, thanks in advanced community!
BeamerKujo is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018