Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-17-2005, 02:22 PM   #1
Micaela
Beemer Fanatic!
 
Join Date: May 2005
Location: Riverside, CA
Posts: 7
1987 325e Acceleration Problem, Help!



Hello,
I am having a problem with my 87 325e. In every gear at between 2.0 and 2.5 rpm the car is stuttering at hard acceleration. Why? I changed out the spark plugs, no change, it actually felt like it was getting worse. It's not the fuel pump, and I am going to change the fuel pump relay today, and check the distributer and rotor, what else should I check?
__________________
Micaela
Micaela is offline   Reply With Quote
Old 05-17-2005, 03:19 PM   #2
JCKL_racing
2nd Gear Member
 
JCKL_racing's Avatar
 
Join Date: Apr 2004
Location: Oakville
Posts: 153
check vacuum lines, afm, throttle butterfly and linkage?
__________________
Max money for Maxbimmers from your Max Financial Services guy. PM for details.
mortgages, leasing, debt consolidation and more
JCKL_racing is offline   Reply With Quote
Old 05-17-2005, 08:40 PM   #3
paul christians
87325is///MR.EVIL
 
Join Date: Feb 2004
Location: ajax
Posts: 7,737
do a leck down test aswell to be safe.........
__________________
87is325///2.7L..EVIL.....
03 beige GRAND AM and 94 white (slamed) PROTEGE
paul christians is offline   Reply With Quote
Old 05-19-2005, 09:33 AM   #4
Griff
2nd Gear Member
 
Join Date: Feb 2005
Location: Toronto
Posts: 53
check the O2 sensor for output, as well as the AFM. My AFM had a dead spot on the potentiometer causing a similar problem. A new (used) AFM cured it. GL

Quote:
Originally Posted by Micaela
Hello,
I am having a problem with my 87 325e. In every gear at between 2.0 and 2.5 rpm the car is stuttering at hard acceleration. Why? I changed out the spark plugs, no change, it actually felt like it was getting worse. It's not the fuel pump, and I am going to change the fuel pump relay today, and check the distributer and rotor, what else should I check?
__________________
Phil Griffin
Toronto, Ontario
'86 325es
'85 VW GTI VR6
Griff is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018