Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 7 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-26-2015, 06:49 AM   #1
Scolirk
2nd Gear Member
 
Scolirk's Avatar
 
Join Date: Jun 2011
Location: Acton Vale, QC
Posts: 78
New E38, Some Problems



Hey all,

I just picked up a new for me 2001 740iL last night. I knew it had some work that needed to be done, but was confident the safety was done and mechanics were in good working order. I drove it home last night for about 300km without issue. The CEL did come on after I filled the tank, but after keeping an eye on my gauges nothing critical appears to be wrong. Will look at getting an OBD2 scanner to diagnose the CEL.

However there are a few small issues that I'd like to try an tackle myself. The navigation screen powers up but doesn't display anything. It'll flicker every little while, and after about 5 minutes the audio stops. A quick off/on of the power switch will fix the audio for another 5 minutes. I imagine a complete Nav swap will solve the issue, but perhaps it's a loose cable?

Also PDC doesn't work, like every other BMW I saw before buying this one. I was told that if one sensor has failed, the entire system shuts off. Is there a way to diagnose myself which sensor(s) have failed and replace them myself?

I apologize if there's a directory or main post for E38 questions that I missed. I did search for some of my issues but nothing came up.

Thanks in advance!
Scolirk is offline   Reply With Quote
Old 09-26-2015, 11:48 PM   #2
Bimmer Heaven
MaXsponsor
 
Bimmer Heaven's Avatar
 
Join Date: Feb 2002
Location: Ontario
Posts: 15,635
Congrats on the E38, they are great cars!

For the Navi screen, the issues is most likely the DVD unit at the rear. The sound ON/OFF issues is the DSP amp, very common...The PDC sensor is a 5 min scan for any shop that know what they are doing, unless you want to buy a scanner that can do that (i highly suggest if you are going to DIY anything on that car!)
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E28 E34 E39 E60 E61 E32 E38 E65 E66 X3 X5 M3 M5 Z4 F30 F32


Call 11-8PM 416 821-2578
New inventory daily. 100+ cars now in stock!
Bimmer Heaven is offline   Reply With Quote
Old 09-27-2015, 09:11 PM   #3
Scolirk
2nd Gear Member
 
Scolirk's Avatar
 
Join Date: Jun 2011
Location: Acton Vale, QC
Posts: 78
Thanks! It was the GPS computer in the trunk that was the problem. I had a local enthusiast help me replace it with some of his stock, fresh MKIII unit in the back now. It does give me a No CD error when starting the car when trying to use the navigation. Not sure if it's a CD problem, or the laser in the computer needs repair.

Either way the radio is working top notch! I'll admit I'm disappointed the bass is on maximum and isn't very noticeable.

Looking forward to being part of this community. Sure would be nice to find some local members and meet ups, compared to the previous communities I've been part of for my other car.
Scolirk is offline   Reply With Quote
Old 09-28-2015, 12:17 PM   #4
740-iLL
Founder of GTA7's
 
740-iLL's Avatar
 
Join Date: Apr 2004
Location: Caledon
Posts: 1,102
Welcome to the E38 family!

You can find a lot of information on E38.org with common problems and detailed fixes.
__________________
Follow me on Instagram @SEVEN40iL
740-iLL is offline   Reply With Quote
Old 09-29-2015, 09:57 AM   #5
Scolirk
2nd Gear Member
 
Scolirk's Avatar
 
Join Date: Jun 2011
Location: Acton Vale, QC
Posts: 78
I've looked through that site, really great info. Already put some if it's info to good use. The next project I want to tackle is the drivers seat. The back cushion has a hole and looks bad. The bottom cushion is fine, so I bought a seat with a better back but rough bottom. Is there any way to replace the entire back, or should I just try to change over the leather cover?

I'll try to post some photos shortly, it's pouring with rain where I am right now.
Scolirk is offline   Reply With Quote
Old 09-29-2015, 12:00 PM   #6
Scolirk
2nd Gear Member
 
Scolirk's Avatar
 
Join Date: Jun 2011
Location: Acton Vale, QC
Posts: 78
This is what I've got in the car right now:




The 'new' seat doesn't include the rear cover/storage or a headrest. It's also got a set of black controls which aren't in great shape. Any suggestions as to what would be the best way to fix this up?
Scolirk is offline   Reply With Quote
Old 10-17-2015, 09:57 PM   #7
xoth3rm1k
1st Gear Newbie
 
xoth3rm1k's Avatar
 
Join Date: Oct 2015
Location: Toronto
Posts: 2
Ditto on e38.org

I just used it today to help replace my trunk shocks
xoth3rm1k is offline   Reply With Quote
Old 10-20-2015, 10:50 AM   #8
Scolirk
2nd Gear Member
 
Scolirk's Avatar
 
Join Date: Jun 2011
Location: Acton Vale, QC
Posts: 78
I've actually fixed most of the issues now. E38.org is a good resource, unfortunately a lot of links don't work anymore.
__________________
2001 BMW 740iL - PRN - Auto Enthusiast Video Content
Scolirk is offline   Reply With Quote
Old 10-20-2015, 11:11 AM   #9
xoth3rm1k
1st Gear Newbie
 
xoth3rm1k's Avatar
 
Join Date: Oct 2015
Location: Toronto
Posts: 2
I recall reading about this recently. Many of the links on e38.org point to bimmerboard forum. Apparently they had a big maintenance recently but are back up now, so the links to some of the stuff you wanted to look up should be back up now.



....am I allowed to name other forums here? I guess we'll find out
xoth3rm1k is offline   Reply With Quote
Old 03-27-2017, 07:25 PM   #10
SHERDIAN BOY
1st Gear Newbie
 
Join Date: Mar 2017
Location: glenwood ill
Posts: 1
I have a 2001 e38 and i have a problem trying to start the car everything works but the car won't make a sound. Battery and starter are good
SHERDIAN BOY is offline   Reply With Quote
Old 03-27-2017, 10:21 PM   #11
Bimmer Heaven
MaXsponsor
 
Bimmer Heaven's Avatar
 
Join Date: Feb 2002
Location: Ontario
Posts: 15,635
Quote:
Originally Posted by SHERDIAN BOY View Post
I have a 2001 e38 and i have a problem trying to start the car everything works but the car won't make a sound. Battery and starter are good
Could be EWS related, very common problem, needs to be realigned...
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E28 E34 E39 E60 E61 E32 E38 E65 E66 X3 X5 M3 M5 Z4 F30 F32


Call 11-8PM 416 821-2578
New inventory daily. 100+ cars now in stock!
Bimmer Heaven is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Maxbimmer Copyright 2001 - 2018