Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-04-2007, 06:25 PM   #1
Bimmerized
In BMW We Trust!
 
Bimmerized's Avatar
 
Join Date: May 2006
Location: London, Ontario
Posts: 225
Send a message via MSN to Bimmerized
Heat Problem E36, please help!!

I have a heat problem. Idle blows cold air, then once reved up it heats up.
Charlie replaced the thermostat but still the same.
Could this be the heater core, or is there anything I can do cus I am freezin in my car??
Bimmerized is offline   Reply With Quote
Old 02-04-2007, 07:38 PM   #2
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,685
Send a message via MSN to propr'one
waterpump?

also, what does the temp gauge read? is the car not getting warm at all?
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 02-04-2007, 07:56 PM   #3
Jon@Bimmersport
MaXsponsor
 
Jon@Bimmersport's Avatar
 
Join Date: Apr 2002
Location: Mississauga
Posts: 13,774
Hmmm, sounds like the heater valve is getting stuck. Your car isnt over heating, so I dont think it would be the new thermostat or even the pump. Maybe you were right...you should move up the street from us, let me know when your comming up ill grab a coffee for you again on the way to work.
__________________

Authorized Ontario dealer for Active Autowerke|VF-Engineering|AFE|Bilstein Suspension|H&R Suspension|KW suspension|Brembo Brake Systems| Stoptech| - Call us for the best pricing please DO NOT PM in regards to pricing

Maintenance|Performance|Tuning & Forced Induction
Jon@Bimmersport is offline   Reply With Quote
Old 02-04-2007, 08:09 PM   #4
Bimmerized
In BMW We Trust!
 
Bimmerized's Avatar
 
Join Date: May 2006
Location: London, Ontario
Posts: 225
Send a message via MSN to Bimmerized
Quote:
Originally Posted by jonny_blaze
Hmmm, sounds like the heater valve is getting stuck. Your car isnt over heating, so I dont think it would be the new thermostat or even the pump. Maybe you were right...you should move up the street from us, let me know when your comming up ill grab a coffee for you again on the way to work.
Is there a DIY for this somewhere?
I really dont want to drive all the way to Miss in this weather!
Bimmerized is offline   Reply With Quote
Old 02-04-2007, 08:28 PM   #5
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,031
Have you topped up your coolant? when my coolant was low I had no flow.
Boots R is offline   Reply With Quote
Old 02-04-2007, 08:51 PM   #6
Jon@Bimmersport
MaXsponsor
 
Jon@Bimmersport's Avatar
 
Join Date: Apr 2002
Location: Mississauga
Posts: 13,774
We just did his thermostat so we re-filled the coolant, we would have noted a leak right then and there...no car leaves our shop with a half done job. You should know that Kev!

Well the heater valve is a bitch to do in the cold, unless u like squeezing inbetween your manifold and master cylinder in -15degrees.
__________________

Authorized Ontario dealer for Active Autowerke|VF-Engineering|AFE|Bilstein Suspension|H&R Suspension|KW suspension|Brembo Brake Systems| Stoptech| - Call us for the best pricing please DO NOT PM in regards to pricing

Maintenance|Performance|Tuning & Forced Induction
Jon@Bimmersport is offline   Reply With Quote
Old 02-04-2007, 09:13 PM   #7
Boots R
Boots, not boost
 
Boots R's Avatar
 
Join Date: Jun 2006
Location: Brampton
Posts: 11,031
Quote:
Originally Posted by jonny_blaze
We just did his thermostat so we re-filled the coolant, we would have noted a leak right then and there...no car leaves our shop with a half done job. You should know that Kev!

Well the heater valve is a bitch to do in the cold, unless u like squeezing inbetween your manifold and master cylinder in -15degrees.
lol I was just unsure how long it had been since the Thermostat was replaced. If he had mentioned that it was replaced recently, i wouldn't have even asked that question.
Boots R is offline   Reply With Quote
Old 02-04-2007, 11:50 PM   #8
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,685
Send a message via MSN to propr'one
Quote:
Originally Posted by jonny_blaze
We just did his thermostat so we re-filled the coolant, we would have noted a leak right then and there...no car leaves our shop with a half done job. You should know that Kev!
No offense jon, but it seems like the heat still doesn't work. That's just a job not done at all.


It could probably be air in the coolant lines, but i doubt that's the case.
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 02-05-2007, 08:37 AM   #9
Bimmerized
In BMW We Trust!
 
Bimmerized's Avatar
 
Join Date: May 2006
Location: London, Ontario
Posts: 225
Send a message via MSN to Bimmerized
JB, I know man, it's the valve, maybe stuck like you said, and I will be there maybe next week sometime. I get heat but not like on idle, and once start moving, or rev just a bit it's nice and warm.

Last edited by Bimmerized; 02-05-2007 at 08:41 AM.
Bimmerized is offline   Reply With Quote
Old 02-05-2007, 10:16 AM   #10
M3ti Compact
Fuel Efficient 318 Member
 
M3ti Compact's Avatar
 
Join Date: Mar 2002
Location: Toronto
Posts: 3,465
My car is the same- no real heat until you push it even when the engine is at normal temp. Check this http://www.maxbimmer.com/forums/showthread.php?t=66769
__________________
M3ti Compact is offline   Reply With Quote
Old 02-05-2007, 01:16 PM   #11
Stephanie
6th Gear Member
 
Stephanie's Avatar
 
Join Date: Jun 2006
Location: Mississauga, ON
Posts: 1,203
my guess it that its the heater control valve, as mentioned above... do u smell any coolant inside the car once you get the heat going?
__________________



Black Sapphire Metallic | Coral Red | Brushed Aluminium | 6MT | ZSP | ZPP | PDC | Bluetooth
Shadowlines | Matte Grilles | Aero Lip | BMW Performance Pedals | Smoked Reflectors | LLumar Tint 40%
KW V2 | VMR V710 | Super Sports | BMS JB4 | BMS DCIs | HPF Intercooler | UUC EVO3 SSK | UUC RK7 Shift Knob
Stephanie is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:20 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.