Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Forced Induction
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-01-2006, 04:12 PM   #16
Darkness95m3
6th Gear Member
 
Darkness95m3's Avatar
 
Join Date: Jan 2005
Location: Ontario
Posts: 2,677
My main problem was the faulty supercharger.
It took 1 year to figure this out.
The other anoying issue was the slipping.
The belt snapped causing the engine to overheat, this caused the head to crack.

This year I had no problems with the supercharger at all.
I believe every FI system has it's problems.
Darkness95m3 is offline   Reply With Quote
Old 12-02-2006, 11:57 PM   #17
The Sly
5th Gear Member
 
The Sly's Avatar
 
Join Date: Aug 2002
Location: L'Ange Gardien, Qc CANADA
Posts: 1,097
Quote:
Originally Posted by bmdbley'sBro
my "reliabilty" problems have pretty much been due to the lack of thought that went into the build of my custom setup.

turbo unsupported. this puts weight on your manifold.
down pipe had no flex piping in it, so it was rigid.
things torq & flex= cracked manifold.

all other issues have been hi-milage related i fi'd at 240km's +
Hey Adam ...i think you were very unlucky with this Turbo setup...
Hope things are going to be better for next summer..
Sly
__________________
The Sly is offline   Reply With Quote
Old 12-03-2006, 05:52 PM   #18
JMW
Pole busted to boosted.
 
JMW's Avatar
 
Join Date: Mar 2006
Location: Mississauga/ Nottingham England
Posts: 2,832
my clutch slips..thats it
__________________

Official Team BIMMERSPORTAUTOMOTIVE vehicle owner.
support: thanks to. Bimmersport automotive and audio 2 go (ATG motoring)


Quote:
Originally Posted by junaid
"i saw your car there when i was there a few weeks ago, looks absolutely stunning man. I think i popped a ****ing boner, that paint looks sick
JMW is offline   Reply With Quote
Old 12-03-2006, 08:48 PM   #19
BMW_7
Econobimmer Racing
 
BMW_7's Avatar
 
Join Date: Dec 2002
Location: Kiev
Posts: 8,363
Send a message via AIM to BMW_7 Send a message via MSN to BMW_7
I'm still on my original clutch after 170k's and a supercharger for 1.5 years! lol
__________________
Vitaliy



Helprace, a helpdesk & community platform
BMW_7 is offline   Reply With Quote
Old 12-03-2006, 09:15 PM   #20
Understated
7th Gear [SMG III] Member
 
Understated's Avatar
 
Join Date: Sep 2003
Location: location location
Posts: 9,955
Quote:
Originally Posted by BMW_7
I'm still on my original clutch after 170k's and a supercharger for 1.5 years! lol
how many KMs have u put on in the past 1.5yrs?
Understated is offline   Reply With Quote
Old 12-04-2006, 12:38 AM   #21
JMW
Pole busted to boosted.
 
JMW's Avatar
 
Join Date: Mar 2006
Location: Mississauga/ Nottingham England
Posts: 2,832
ye but i got way toi much power for my clutch
__________________

Official Team BIMMERSPORTAUTOMOTIVE vehicle owner.
support: thanks to. Bimmersport automotive and audio 2 go (ATG motoring)


Quote:
Originally Posted by junaid
"i saw your car there when i was there a few weeks ago, looks absolutely stunning man. I think i popped a ****ing boner, that paint looks sick
JMW is offline   Reply With Quote
Old 12-04-2006, 01:13 AM   #22
Furious
BMW again.
 
Furious's Avatar
 
Join Date: Feb 2002
Location: Toronto
Posts: 6,088
Quote:
Originally Posted by Pure GQ
ye but i got way toi much power for my clutch
how much power did you get the dyno done yet? stock m3 clutch i assume.
Furious is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:14 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014