Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-27-2006, 10:23 PM   #1
Ant118
BmwAviator
 
Ant118's Avatar
 
Join Date: Dec 2004
Location: OakRidges
Posts: 3,047
Speedo Issue?

Sometimes when the car has been sitting for a while the speedo doesnt seem to work, but it will start to and then die.
__________________
1997 Estoril Blue ///M3 - Track Car

2011 Alpine/Black 335is
Ant118 is offline   Reply With Quote
Old 08-28-2006, 01:13 AM   #2
Big T
94 318is
 
Join Date: Aug 2005
Location: Waterloo, Canada
Posts: 409
Same problem over here, it kicks in after 100km/h
__________________
Big T is offline   Reply With Quote
Old 08-28-2006, 01:13 AM   #3
mellobudd
jumblebee
 
mellobudd's Avatar
 
Join Date: Aug 2006
Location: Toronto
Posts: 934
Send a message via MSN to mellobudd Send a message via Yahoo to mellobudd
i think its the ground inside your instrument cluster, same thing happened on my car.. i used to tap it.
mellobudd is offline   Reply With Quote
Old 08-28-2006, 01:17 AM   #4
mellobudd
jumblebee
 
mellobudd's Avatar
 
Join Date: Aug 2006
Location: Toronto
Posts: 934
Send a message via MSN to mellobudd Send a message via Yahoo to mellobudd
take the instrument cluster off, open the back of it and look for loose screws..
mellobudd is offline   Reply With Quote
Old 08-28-2006, 01:45 AM   #5
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,685
Send a message via MSN to propr'one
Check the diff cable too (sensor in the differential)
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 08-28-2006, 08:52 PM   #6
Ant118
BmwAviator
 
Ant118's Avatar
 
Join Date: Dec 2004
Location: OakRidges
Posts: 3,047
Thanks im gonna try that in the morning.
__________________
1997 Estoril Blue ///M3 - Track Car

2011 Alpine/Black 335is
Ant118 is offline   Reply With Quote
Old 08-29-2006, 01:21 PM   #7
cisco911
6th Gear Member
 
Join Date: Nov 2005
Location: toronto
Posts: 1,511
E36 clusters have always had problems. However, usually your gas and RPM go first. You might have to start looking for a used one.
__________________
I'm just a crazy m*thrf*cker, livin it up, not givin a f*ck, living life in the fast lane
cisco911 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.