Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Audio/Sound
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-24-2006, 02:53 PM   #1
cisco911
6th Gear Member
 
Join Date: Nov 2005
Location: toronto
Posts: 1,511
Radio signal quality

Hey guy. I've had my E46 for a while now, but I'm just wondering if people have the same problem as me because it is starting to bug me. I find that my radio does not pick up radio station signals very well. if wil be good for a while and then fade. I know my car has the antenna in the windshield and I know that its the original windshield, so no worries about it being because of an aftermarket windshield install. Just want to know if this is a common problem or is there something I can fix. It doesn't bug me too much since I'm always listening to CDs not the radio, but if there is a solution, I would love to know what it is. I also live in toronto, so I'm thinking maybe there is too much interference for it to catch a good signal.

Thanks guys
__________________
I'm just a crazy m*thrf*cker, livin it up, not givin a f*ck, living life in the fast lane
cisco911 is offline   Reply With Quote
Old 02-24-2006, 03:00 PM   #2
Justin e36
---
 
Justin e36's Avatar
 
Join Date: May 2003
Location: etobicoke
Posts: 12,331
Send a message via ICQ to Justin e36 Send a message via AIM to Justin e36 Send a message via Yahoo to Justin e36
Yep, there was a recall for this. The antenna booster plug from behind your stereo, and attached to your antenna booster itself sometimes comes loose.

Your antenna is not in your windshield, it's in your rear window. There are 3 antenna lines on there.

Justin
Justin e36 is offline   Reply With Quote
Old 02-24-2006, 03:21 PM   #3
cisco911
6th Gear Member
 
Join Date: Nov 2005
Location: toronto
Posts: 1,511
So should I remove the stereo to see if the booster cable is lose??? Or does it come lose at the booster?

Thanks alot...if its something that simple I'm gonna kick myself for not asking sooner!!!
__________________
I'm just a crazy m*thrf*cker, livin it up, not givin a f*ck, living life in the fast lane
cisco911 is offline   Reply With Quote
Old 02-24-2006, 08:40 PM   #4
Justin e36
---
 
Justin e36's Avatar
 
Join Date: May 2003
Location: etobicoke
Posts: 12,331
Send a message via ICQ to Justin e36 Send a message via AIM to Justin e36 Send a message via Yahoo to Justin e36
According to the recall, it's at the antenna booster.
Remove the trim piece on your C-Pillar (driver's side), and the antenna booster is inside. Disconnect, clean, and reconnect the booster cable. Also try wiggling it while the radio is on.

Here is the technical service instructions for your car: http://www.openbmw.org/downloads/65%...0amplifier.pdf

Hope this helps...
Justin e36 is offline   Reply With Quote
Old 02-24-2006, 09:04 PM   #5
cisco911
6th Gear Member
 
Join Date: Nov 2005
Location: toronto
Posts: 1,511
Thanks alot for taking the time justin. I'll probably take a look at that tommorrow.
__________________
I'm just a crazy m*thrf*cker, livin it up, not givin a f*ck, living life in the fast lane
cisco911 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.