Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-13-2005, 03:26 PM   #1
tomski
1st Gear Newbie
 
Join Date: Nov 2004
Location: Mississauga
Posts: 10
My e28 is down.

Yesterday I replaced my leaking hydraulic booster on my 87 535i, with a used unit. I took the car for a test run to make sure all was ok, no leaks and every thing looked good. Later on in the evening, heading out for a couple of beers, I get on the QEW, take an exit on Park Lawn N , I go to down shift, nothing, I lost all of the gear selection. I managed to get over the left side, right were you take an West bound exit, so I was not in the middle of the road. I stopped and go to depress the clutch pedal, gone, no pressure nothing.
I towed the car home, no choice. I looked at the clutch pedal to see what happened, it looks like the clevis bolt that is attached to the master cylinder just broke off. The main thing that worries me is the shift lever. Hopefully it's nothing major, and something that I can fix. I will have a closer look at it tomorrow, in that case any suggestions as to what to look for are most appreciated. Thanks
tomski is offline   Reply With Quote
Old 02-13-2005, 05:59 PM   #2
Ted in T.O.
3rd Gear Member
 
Join Date: Jun 2003
Location: Mississauga
Posts: 505
breakdown

Hey Tomski.. Post the question on the mye28.com website in the old forum.Let them know that you are a newbi and do not own a Bentley manual just yet but you will buy one.there are alot of guys on this website that can help you with the problem.My guess is you lost all your brake fluid in own of the lines .Perhaps you did not tighten one of the hose clamps.You probably did not damage the shift lever.Just say what you said on this board and the E28 boys will look after you. Good luck.Ted in T.O.
Ted in T.O. is offline   Reply With Quote
Old 02-18-2005, 11:49 PM   #3
Ted in T.O.
3rd Gear Member
 
Join Date: Jun 2003
Location: Mississauga
Posts: 505
E28 up and running yet Tomski?
Ted in T.O. is offline   Reply With Quote
Old 02-20-2005, 12:21 AM   #4
tomski
1st Gear Newbie
 
Join Date: Nov 2004
Location: Mississauga
Posts: 10
Hi Ted. The e28 is still down. I did not touch the car, cold weather, work and a little lack of motivation towards the job. I will start by taking a look at the shift linkage, and go from there. On a side note, looking at autotrader a nice e28 for sale, a little far but very nice.... Cheers

http://www.canadatrader.com/result/d...3789760&pgno=1
tomski is offline   Reply With Quote
Old 02-20-2005, 10:38 AM   #5
Ted in T.O.
3rd Gear Member
 
Join Date: Jun 2003
Location: Mississauga
Posts: 505
There is one nicer than that with only 10,000 KM just outside of Waterdown for $8,200.It's a 528e automatic though.
Ted in T.O. is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:51 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014