Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-05-2004, 03:15 AM   #1
nseverin
2nd Gear Member
 
nseverin's Avatar
 
Join Date: Jul 2003
Location: Scarborough
Posts: 239
Engine Over Cooling

Its now 4 C (40 F) outside up here in the Great White North. I noticed
my temp guage is going up to the first slash after the blue mark. I swear
it always sits at the half way mark in summer or winter. It might be my
thermostat. Any input on this from anyone? What does yours look like?
Help. Thanks.
nseverin is offline   Reply With Quote
Old 11-05-2004, 09:06 AM   #2
1BADRIDE
TECHGURU
 
Join Date: Aug 2004
Location: Lakefield, ON
Posts: 1,890
Send a message via MSN to 1BADRIDE
Check T-stat and also coolant level.
__________________
2010 BMW 335D - Many mods to come!
1BADRIDE is offline   Reply With Quote
Old 11-05-2004, 10:17 AM   #3
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
also fan clutch
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 11-05-2004, 12:12 PM   #4
///Greco540
4th Gear Member
 
///Greco540's Avatar
 
Join Date: Dec 2002
Location: Montreal
Posts: 766
Sounds like thermostat is stuck open...
__________________
//Greco540
'98 (04/98) 540i/6 Biarritz Blue / Sand Beige
Options: 17" Style 32 Staggered / Sport Seats / Xenons / Sport Suspension / 6 Speed / Cold weather Pkg
Mods: M5 Grill, CDV, AE Xenons, Rogue Engineering Octane Short Shifter w/ WSR, Rogue Engineering Performance Transmission Mounts, Royal Purple Synchromax Transmission Fluid, Gruppe M Filter Ram Charger


My Car Site
///Greco540 is offline   Reply With Quote
Old 11-06-2004, 07:34 AM   #5
nseverin
2nd Gear Member
 
nseverin's Avatar
 
Join Date: Jul 2003
Location: Scarborough
Posts: 239
it was i suspected and what all ya'll suspected!
the T-stat. Changed it yesterday in 20 minutes.
I've changed T-stats on other cars before but never
has it ever been so easy!!!!
Damn them Germans really know how to make a machine!!!
Thanks
nseverin is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:43 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.