Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-09-2004, 09:38 PM   #1
bmdoubleya
6th Gear Member
 
bmdoubleya's Avatar
 
Join Date: Jan 2003
Location: Ottawa
Posts: 2,002
Clutch feels very soft???

Just took the car out for its first drive in 4 months. About 2 weeks after I stored the car the clutch went just droped to the floor like the slave cyl was broken.....Now it works fine but feels a little spongie?? any ideas Thanks
bmdoubleya is offline   Reply With Quote
Old 03-10-2004, 08:01 AM   #2
crazyvadim
6th Gear Member
 
crazyvadim's Avatar
 
Join Date: Nov 2003
Location: New York
Posts: 2,178
Send a message via AIM to crazyvadim
Re: Clutch feels very soft???

Quote:
Originally posted by bmdoubleya
Just took the car out for its first drive in 4 months. About 2 weeks after I stored the car the clutch went just droped to the floor like the slave cyl was broken.....Now it works fine but feels a little spongie?? any ideas Thanks
See if theres enough fluid in the reservoir,you might have a leak.You might also have air inside the system,try bleeding it.....there should be a bleeder screw on the slave cylinder.
crazyvadim is offline   Reply With Quote
Old 03-10-2004, 03:45 PM   #3
chromius
6th Gear Member
 
chromius's Avatar
 
Join Date: Dec 2002
Location: Ottawa
Posts: 4,006
Re: Clutch feels very soft???

Quote:
Originally posted by bmdoubleya
Just took the car out for its first drive in 4 months. About 2 weeks after I stored the car the clutch went just droped to the floor like the slave cyl was broken.....Now it works fine but feels a little spongie?? any ideas Thanks
Not positive, but you could check under the dash at the adjustment spring, if this is not adjusted properly it might feel loose or spongy....you could try and tighten it up. just a thought.
__________________
Photobucket
chromius is offline   Reply With Quote
Old 03-10-2004, 10:43 PM   #4
bmdoubleya
6th Gear Member
 
bmdoubleya's Avatar
 
Join Date: Jan 2003
Location: Ottawa
Posts: 2,002
Thanks guys I will check both
bmdoubleya is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:34 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014