Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-18-2004, 04:49 PM   #1
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
E36 heating problems!!!!

i have a 97 328i and my heating unit is ****ed. when i try to turn the heat on sometimes it wont come on at all. then if it does go on then like 10 min later the screen will either go black but the light for the direction of the air will be on still, and i cant change any settings, or it will turn on off on off on off until it either shuts off or turns on. the radio screen also go black well the lite goes out and u can kinda make out the screen. and chooses when to come on or not but the radio sounds fine and plays fine. its just the display, the heat is the display and it wont work right. i am in need of some serious help!!!!
beamerboycsl is offline   Reply With Quote
Old 02-18-2004, 07:26 PM   #2
JDub
3rd Gear Member
 
Join Date: Jan 2002
Location: Toronto, ON
Posts: 469
I had both of those problems at different times. When I had the radio display problem, I asked the dealer about it and they said that the radio will work but you would have to replace the entire unit to get the lights to work. I solved that problem by getting an aftermarket deck.

As for the heater, I just had the exact thing happen to me 2 weeks ago. Found out it was the thermostat. Is your engine temperature guage going to the middle when you drive?
__________________
97 328i SOLD
04 330Ci
JDub is offline   Reply With Quote
Old 02-18-2004, 08:35 PM   #3
A~G
Car Payment Free
 
A~G's Avatar
 
Join Date: May 2002
Location: Toronto
Posts: 7,581
Send a message via MSN to A~G
^^^ i was just gonna say thermostat... though changing the thermostat is just a temporary fix. problem usually re-occurs down the road. I drive a mazda.. so thatz how i solved my problem.
__________________



A~G

Man who run in front of car get tired.
Man who run behind car get exhausted.
A~G is offline   Reply With Quote
Old 02-19-2004, 04:01 AM   #4
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
yea but would the thermostat not let me change anyof my setting via defrost, temp, postion of the air, level of air??? its kinda like it freezes to put it the best. and when ever she freezes she stays on what ever shes at and u cant change it.
beamerboycsl is offline   Reply With Quote
Old 02-19-2004, 01:12 PM   #5
JDub
3rd Gear Member
 
Join Date: Jan 2002
Location: Toronto, ON
Posts: 469
My heater was shutting off and coming on by itself and it happened when I pushed buttons too. After I got it fixed, no more problems.
__________________
97 328i SOLD
04 330Ci
JDub is offline   Reply With Quote
Old 02-19-2004, 02:53 PM   #6
Desisuperman
4th Gear Member
 
Join Date: Jan 2004
Location: Brampton
Posts: 651
Same probz

I got the same problem with the radio.. lol if u bang the dash a few times and if i'm lucky it sometimes lights up again. As fas as the heater goes, no problem with the dipslay but sometime si get this weird squealing noise after the heat's been on for a while
__________________
TiMe Is NeVer WaSteD WheN YouR WaSTEd All The TiMe

01 540i-M 6spd
Desisuperman is offline   Reply With Quote
Old 02-19-2004, 05:18 PM   #7
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
eya i get that to and its kinda when i hit the brakes but its hard to tell if its just random. but it sounds like that fan. that only happend one night and it was like 3 weeks ago. what is that all about 2.
thanks
beamerboycsl is offline   Reply With Quote
Old 02-19-2004, 05:48 PM   #8
Desisuperman
4th Gear Member
 
Join Date: Jan 2004
Location: Brampton
Posts: 651
dunno man, my prob with the heate comes n goes dunno what it is either
__________________
TiMe Is NeVer WaSteD WheN YouR WaSTEd All The TiMe

01 540i-M 6spd
Desisuperman is offline   Reply With Quote
Old 02-20-2004, 09:41 PM   #9
Alwysfresh
Registered User
 
Alwysfresh's Avatar
 
Join Date: Oct 2002
Location: Toronto
Posts: 265
If the screen is turning on and off and the fan seems to have a mind of its own it is your heater control unit. Same thing happened on mine...it's a common problem on these things. I had my old one rebuilt recently and I'm trying to unload it if you're interested. It's very easy to install on your own. I'll give you a good price if you want it (they're $450CAD new from the dealer, I paid $220CAD for the rebuild)...let me know.
Alwysfresh is offline   Reply With Quote
Old 02-26-2004, 07:32 PM   #10
beamerboycsl
3rd Gear Member
 
Join Date: Dec 2003
Location: Mass
Posts: 326
Send a message via AIM to beamerboycsl
ok. well i got help on how to fix it myself. i guess a sodiered part broke but for about 5 bucks i can repair it myself. but BMW NA called me and is setting up a appointment for the screen.
beamerboycsl is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:56 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.