Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 02-23-2004, 11:26 PM   #1
thinair
moderationistismingly
 
thinair's Avatar
 
Join Date: Dec 2001
Location: Bradford, ON
Posts: 8,794
Send a message via MSN to thinair
Finally installing my M50 manifold

Well, to start let me say I have no digital camera and I really wish I did so I could do a proper write up or something.

Today I spent some time trying to remove the stock intake manifold off my engine. It looks pretty easy judging by the online DIY's and the Bentleys Manual. It's a little more involved I guess, thing get tighter in real life then how they look in pictures.

To start I already had the valve and fuel rail covers off. I removed the intake elbow connected to the throttle body, the HFM, the alternator cooling duct, and unbolted the throttle body from the manifold.

The 2 bolts came off holding on the fuel rail and injectors, and it pulled right off the manifold.

I then removed the 7 nuts holding the manifold to the block, and the two bolts holding the manifold to the manifold support brackets.

This is where things got interesting, I removed the vacuum line to the brake booster, the crankcase vent tube, and lifted the manifold a little to get some access under the manifold. I had to remove the front manifold support off the block too. There are two small vacuum lines that were a pain to get out, and I had to unbolt the thing that is connected to the crankcase vent and the ICV. Undo a bunch of hose clips and sensor plugs and it came out. I think it took me like an hour and a half just to remove it.

I managed to drop one nut that was holding the manifold on. Until now it's still reported missing.

Tomorrow I'll try to install the M50 manifold with the Eurospeed hoses/install kit and hope everything works and that I don't get a CEL.

Then swap software with the M50 chip.
__________________
"Driving is like a narcotic, an addiction that can take over lives. It ruins people, breaks families apart, and even kills. Itís habit that needs to be fueled. Time, money, rationality, sweat, knuckle skin, and anyone who disapproves are of little importance to a driver, and are often overlooked. Hi, Iím Nelson, and Iím a drivaholic."
thinair is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:26 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014