Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 02-20-2004, 12:42 AM   #1
snd84318i
3rd Gear Member
 
snd84318i's Avatar
 
Join Date: Oct 2003
Location: nyc
Posts: 378
Angry power problem

yesterday the car starting ackting funny .15 mins into my drive to work the car lost its power . pulled over ,sounded like it was choking then it ceared upand drove fine . on why way back home ,almost here it happened again .i ajusted the idle control unit screw . opened it some and in seconds it ran normal.today ran the same ,good, on the way home it didnt stop running but i couldnt get it past 3000 rpms if i pushed the gas peddle down for more power it will slow down and lose rpms . im not ure what will cause this . i read haynes and it says a few tings air filter clogged . mines a k@n just put in 2 mnths ago . gas fitler not yet change vacume leak ,dont know were to check for that, afm looks stock . any help guys thanks
snd84318i is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:02 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014