Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > Track Junkies
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-04-2002, 10:05 PM   #1
A~G
Car Payment Free
 
A~G's Avatar
 
Join Date: May 2002
Location: Toronto
Posts: 7,581
Send a message via MSN to A~G
Smile MAZDA 626 89' vs VOLVO V70 01???

OMG... Today I was coming home from Wasaga beach... taking the 400 south... i'm cruising with a few buddies in the car (who were sleeping ) going about 120km/hour. All the sudden a pack of about 5 cars zoom by me going about 160km/hour.. average... obviously i jumped on the chance to stick with'em'..c'mon the cops can't possibly pull all of us over... . So the Accord, CRV and a few others pull over to a Mickey-Dees and its only me (Mazda 626 89') and the Volvo V70,,, the guy looks over and kinda invites me to have some fun... i was like... ... i don't know.. so he pushes up to about 180km/h so i got up to 180... next he pulls up to about 200K/hour!!! i was like .... ... so i pulled my shitbox up to about 205k/h or so... the guy just pulled away like ... i mean don't those cars have limits!!! i could have sworn he took it up to atleast 220!... anyways i'm just happy i didn't have an engine fire or something ...haha.. and no piggies either SO WHAT I WANTED TO ASK WAS... after i got off the highway after pulling about ..we'll say 150/h average and up to 205/h at times... my car was kinda lacking in power... i mean it was like i was running on 30hp or something ... whats that all about... did something break or was the engine just worn ? i'll see how it is tommorow.
__________________



A~G

Man who run in front of car get tired.
Man who run behind car get exhausted.
A~G is offline   Reply With Quote
Old 07-05-2002, 01:25 PM   #2
A~G
Car Payment Free
 
A~G's Avatar
 
Join Date: May 2002
Location: Toronto
Posts: 7,581
Send a message via MSN to A~G
uuugh

...uuugh.. its still seems like its lagging a little
__________________



A~G

Man who run in front of car get tired.
Man who run behind car get exhausted.
A~G is offline   Reply With Quote
Old 07-05-2002, 02:44 PM   #3
330DTM
Cinematographer
 
330DTM's Avatar
 
Join Date: Dec 2001
Location: T dot O
Posts: 3,080
Send a message via ICQ to 330DTM Send a message via MSN to 330DTM
What kind of V70 was it?
Was it the base V70?
the light pressuered turbocharged one?
or the high pressured turbocharged?
__________________
-=Slow In Fast Out=-
330DTM is offline   Reply With Quote
Old 07-05-2002, 07:09 PM   #4
Mr seville
6th Gear Member
 
Mr seville's Avatar
 
Join Date: Jan 2002
Location: places
Posts: 4,849
yeah i use v70 t5's sometimes on weekends those thing are friggen quick believi it or not!!! 245hp
Mr seville is offline   Reply With Quote
Old 07-05-2002, 11:10 PM   #5
jello_g
4th Gear Member
 
jello_g's Avatar
 
Join Date: May 2002
Location: Toronto, ON, Canada
Posts: 720
G~G, what motor do you have in your 626? May I suggest you check out www.mx6.com and/or www.probetalk.com - both vehicles shared similar if not identical motors back in the time. Good luck!
__________________
1988 BMW Dinan M3 2.6 Stage II

Gerald Lau's Facebook profile
jello_g is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:24 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.