Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-30-2003, 04:13 AM   #1
Soldo
6th Gear Member
 
Soldo's Avatar
 
Join Date: Oct 2002
Location: Toronto
Posts: 12,484
Angry Gas meter all F*%& up

Hey guys, my gas guage is all messed up, i dunno why. Last week i was gone all week and my car was on quarter tank and wasn't turned on for a good week, then i came back drove it around a bit and filled up the tank, and when i turned the car back on i noticed the gas was still on 1/4 tank so i drove it around and when i turned it back on a half hour later it went to the fill line, FINALLY!
so then this morning i filled my tank up again, and now the same thing happened but it still hasn't gone back up, and when i turn the car on its COMPLETELY empty on the guage even though the tank is FULL, anyone else have this problem, or know what the hell is going on!?
Thanks guys
Soldo is offline   Reply With Quote
Old 07-30-2003, 06:38 AM   #2
MP328
Krv Svoju Za Bosnu Moju
 
MP328's Avatar
 
Join Date: Feb 2002
Location: Brampton
Posts: 2,583
Send a message via MSN to MP328
i had that before happening. usually when i overfilled it, it would happen. do u always fill up until the gas starts coming out? i used to and that would happen. now i just stop when the pump jumps out the first time.

the first time that happen to me was a while back. i just filled it up all the way and took of the gas station, and the needle was like only at 1/2 tank, like wtf. so i pull in in the next gas station again and try to fill it up and get only like 20 cents in hehe. the guy was looking all strange at me when i was paying.

since my car was still under warranty at that time, i brought it in and told the dealership about it. and they just told me to stop overfilling it. and if it still doesnt stop doing that, then that piece that's floating inside ur gas tank is ****ed up
MP328 is offline   Reply With Quote
Old 07-30-2003, 10:26 AM   #3
maverick
5th Gear Member
 
maverick's Avatar
 
Join Date: Jun 2002
Location: Brampton
Posts: 1,018
Send a message via ICQ to maverick
the fuel tank sending unit might be screwed up

do you use petro canada a lot??? they had a problem about a month ago with their gas, the sulphur content was extreamly high and a lot of people started bringing their cars to the dealerships cause their fuel meters stoped working after a bunch of cars with the same problems started showing up they traced it back to the gas company also shell shares gas with petro so same deal if you use them. I never did hear if the gas company was paying for the repairs or reimbursing those effected.
__________________

PIMP'N AIN'T EASY
especially in a sunturd
maverick is offline   Reply With Quote
Old 07-30-2003, 07:12 PM   #4
Soldo
6th Gear Member
 
Soldo's Avatar
 
Join Date: Oct 2002
Location: Toronto
Posts: 12,484
FAKKKKKKKKKK!
Ya i filled up with SHELL both times!!!
DAMMIT!!
so what, if i start puttin sunoco back in should it FIX itself, or does it need to be manually repaired!
__________________
Keven Soldo
Soldo is offline   Reply With Quote
Old 07-30-2003, 07:40 PM   #5
maverick
5th Gear Member
 
maverick's Avatar
 
Join Date: Jun 2002
Location: Brampton
Posts: 1,018
Send a message via ICQ to maverick
you can try it and pray it rights it self but not too often does a fuel sending unit repair itself it has to do with the components being burned (corroded) from the sulphur.
I was using petro can too I haven't used it since I heard the story on the news.
__________________

PIMP'N AIN'T EASY
especially in a sunturd
maverick is offline   Reply With Quote
Old 07-30-2003, 08:02 PM   #6
bmwm5lover
is BMW crazy
 
bmwm5lover's Avatar
 
Join Date: Sep 2002
Location: Thornhill
Posts: 15,334
damn, ive been using petro too!
__________________
www.enthusiastauto.caNeed a car???

His--'00 BMW ///M5 .:Jet BLK/BLK:. Individual - Style 65 Wheels; 9.5" Square Set up;275 Tires;10mm/3mm Spacers; Black Kidneys;Muffler Delete; 3.5" Dual Tips; Beast Power; "Dinan" Ducts; E60 SSK; BC Coils
Hers--'00 BMW ///M5 .:Avus Blue/Grey/Black:.
Toys
'88 BMW 635CSi Blue/Tan Sport
'81 MB 500 SEC Euro Koenig
'91 Alfa Romer 164S- Red/Black/ Recaro interior
bmwm5lover is offline   Reply With Quote
Old 07-30-2003, 08:52 PM   #7
chitown
4th Gear Member
 
Join Date: Jul 2003
Location: Georgetown
Posts: 831
Same, heh

Back to Sunoco I guess
chitown is offline   Reply With Quote
Old 07-30-2003, 08:56 PM   #8
maverick
5th Gear Member
 
maverick's Avatar
 
Join Date: Jun 2002
Location: Brampton
Posts: 1,018
Send a message via ICQ to maverick
im sure there gas is fine now the car that got hit the worst was the pontiac Sunfire dont ask me why but those cars were going in to the dealerships by droves replacing the fuel sending units and gas tank seals.
__________________

PIMP'N AIN'T EASY
especially in a sunturd
maverick is offline   Reply With Quote
Old 07-30-2003, 10:49 PM   #9
Soldo
6th Gear Member
 
Soldo's Avatar
 
Join Date: Oct 2002
Location: Toronto
Posts: 12,484
could it be because of anything else though?!
__________________
Keven Soldo
Soldo is offline   Reply With Quote
Old 07-31-2003, 12:27 AM   #10
Quack
Wheelman
 
Quack's Avatar
 
Join Date: Jul 2002
Location: Toronto
Posts: 12,058
Send a message via MSN to Quack
good job maverick, most people don't pick that up, I insist that everyone stays away from Shell gas, they are by far the worst, nothing but Sunoco goes into my tank, they sulpher rating in Shell gas is over 440ppm, while Petro and Esso has about 240ppm, Sunoco has the lowest sulpher rating, once your fuel level sensor is malfunctioning you should replace it, it will not fix itself.
__________________

Maxbimmer Drama, You Gotta Love It
Quack is online now   Reply With Quote
Old 07-31-2003, 01:00 AM   #11
moregothanshow
All Show No Go!
 
moregothanshow's Avatar
 
Join Date: Apr 2003
Location: Toronto
Posts: 1,481
my gas guage used to never go completely full no matter how much gas i put in it and it was only sunoco.... but after i started using the canadian tire fuel injector cleaner (pink bottle with 5 uses) the fuel meter would show full and some so i am guessing that fuel injector cleaner shit must have did something to the tank along the way.....just sharing my experience...
__________________
moregothanshow is offline   Reply With Quote
Old 07-31-2003, 03:06 AM   #12
Soldo
6th Gear Member
 
Soldo's Avatar
 
Join Date: Oct 2002
Location: Toronto
Posts: 12,484
thanks guys, so those cacksuckers at shell screwed me i guess!!
Oh well back to the good ol days of the 94 octane!
__________________
Keven Soldo
Soldo is offline   Reply With Quote
Old 07-31-2003, 03:46 AM   #13
330DTM
Cinematographer
 
330DTM's Avatar
 
Join Date: Dec 2001
Location: T dot O
Posts: 3,080
Send a message via ICQ to 330DTM Send a message via MSN to 330DTM
Quote:
Originally posted by SOLDOMATIC 325i
thanks guys, so those cacksuckers at shell screwed me i guess!!
Oh well back to the good ol days of the 94 octane!
Actually I don't have any problems with Shell for my Toyota Corolla and the Volvo.

However back when I had the 328, I did experience some problems with the gas metre and don't know if it was the Shell gas or just one of the faulty sensors. Eventually the dealer replaced the sensor and I think something else and I continued to fill it up with Shell gas without any problems.
__________________
-=Slow In Fast Out=-
330DTM is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.