Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Audio/Sound
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-21-2003, 03:03 PM   #1
330DTM
Cinematographer
 
330DTM's Avatar
 
Join Date: Dec 2001
Location: T dot O
Posts: 3,081
Send a message via ICQ to 330DTM Send a message via MSN to 330DTM
Problems with rims?

I just want to see what your experiences are like with aftermarket rims and if you have any problems with it. Also how do you find the ride quality compared to stock with the new rims and did you ever run into problems of bent rims due to road hazards?

Ever since I installed the Mille Miglia MM11-2's on my Volvo wagon, the ride seems pretty harsh. Specs 205/45/17. The car is pretty heavy but I doubt heavier than an E34 5'er. I don't know if it's my suspension that's messed up but the ride is way too harsh. Any ideas? Even with the correct tire inflation it's still stiff on the bumps and I have stock suspension.

Any ideas?
__________________
-=Slow In Fast Out=-
330DTM is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:50 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014