Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-21-2014, 01:11 AM   #15
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,948
Quote:
Originally Posted by Allyox View Post
I went to go bring my car into a mechanic who was willing to do a diagnosis test on it! So far he couldn't figure out the problem and a lot of problems came up on the diagnosis test. I got my boyfriend and father to mess around with the battery cables one day because just recently the car has been dying in the middle of the road and when I try to boost it up again it takes at least 10 tries for it to restart and then I get a notification on my car saying "check battery terminals" ever since my boyfriend and dad messed around with the cables the "check engine: increased emissions" light has gone off and the only notifications I get are "coolant level low" "high battery drain" and "passenger restraint"! The car was working perfectly after and I had no transmission faults on the way home until just recently the computer screen would start to flicker on and off and luckily I was able to get home the moment I shut off my car and tried to restart it, it would not restart and I have to boost it again to get it working! After that had happened my car now sends off notifications such as "engine temperature too hot" and when I shut my car off and lock it the engine fans are still running in my car to cool it down. The will ultimately drain my battery now! If anyone has any idea what's going on with my car please let me know! And maybe could you quote me how much each part would be to fix it! I'm really disappointed with my purchase and I figured since it's a bmw that it would be a reliable car! Was I ever wrong! Let me know what I should do I could use all the advice I could get right now
#1 thing to do is bring it to a GOOD BMW shop (no, not the dealer).
The E60 is notorious for water leaks in the trunk, where a LOT of the electronics are. The early ones, like your 04 have a MPM (micro power module) that can shut power to a lot of components, very common problem.
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
 

Tags
2004 545i, e60, problem, transmission

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.