Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-10-2014, 03:27 PM   #1
dee0007
2nd Gear Member
 
Join Date: Feb 2012
Location: Mississauga
Posts: 84
E46 330i ZHP Starting problems, Need Help

Hi Guys, I have a problem starting my car.
Basically when i turn the ignition the car will not start, just keeps cranking , in order to start i have to crank for about 4 sec and add gas otherwise it will stall.
This problem does not happen all the time only under certain circumstances.
For example if I drive the car and try to start it after few hours. When the engine is still relatively warm. In the mornings recently when the temperatures were really low, I had no problems starting it, usually started after the first turn.

I read somewhere that it most likely is the fuel filter. It is not in my case, I changed the filter and the problem still there!

Anyone had this issue before?

One mechanic told me that its the MAF sensor, I m worried that if I spend money on MAF it might not fix the issue and I would of changed already two things that were not necessary.

Any thoughts? suggestions?

Thanks
dee0007 is offline   Reply With Quote
Old 01-10-2014, 08:53 PM   #2
G12
G12
 
Join Date: Jan 2013
Location: Base Borden/Barrie
Posts: 54
Sounds like low fuel pump pressure, is there hesitation while accelerating?
__________________
G12 is offline   Reply With Quote
Old 01-10-2014, 11:07 PM   #3
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,951
Go to a GOOD mechanic, that has experience with these cars. It could be a lot of things, but they are have pretty specific symptoms. Fuel filter is a maintenance item, so NOT a waste if you changed it! Also check tune up parts such as plugs, oil separator, ALL rubber hoses (air leak will cause this, needing more fuel in order to start). Crank sensors can also cause this, along with gas tank vent valves. So pretty much a TON of possible issues, and a good scan should be able to pin point it! (key word GOOD!)
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 01-11-2014, 08:34 AM   #4
dee0007
2nd Gear Member
 
Join Date: Feb 2012
Location: Mississauga
Posts: 84
Quote:
Originally Posted by G12 View Post
Sounds like low fuel pump pressure, is there hesitation while accelerating?
It does hesitate only on second gear between 2500-3000rpm. It chokes.
dee0007 is offline   Reply With Quote
Old 01-11-2014, 08:35 AM   #5
dee0007
2nd Gear Member
 
Join Date: Feb 2012
Location: Mississauga
Posts: 84
Quote:
Originally Posted by Eurostyle View Post
Go to a GOOD mechanic, that has experience with these cars. It could be a lot of things, but they are have pretty specific symptoms. Fuel filter is a maintenance item, so NOT a waste if you changed it! Also check tune up parts such as plugs, oil separator, ALL rubber hoses (air leak will cause this, needing more fuel in order to start). Crank sensors can also cause this, along with gas tank vent valves. So pretty much a TON of possible issues, and a good scan should be able to pin point it! (key word GOOD!)
Couldn't agree more. Any suggestions in the west end of GTA?
dee0007 is offline   Reply With Quote
Old 01-11-2014, 02:52 PM   #6
jabela
4th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 748
Another guy on maxbimmer just had a similar issue and after he unplugged the MAF it started fine for him, so maybe give that a shot.
However, if you have over 120k km on your car and haven't replaced the fuel pump and filter, than that's a good idea too.
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.modernapothecary.ca
jabela is offline   Reply With Quote
Old 01-11-2014, 04:44 PM   #7
dee0007
2nd Gear Member
 
Join Date: Feb 2012
Location: Mississauga
Posts: 84
Quote:
Originally Posted by jabela View Post
Another guy on maxbimmer just had a similar issue and after he unplugged the MAF it started fine for him, so maybe give that a shot.
However, if you have over 120k km on your car and haven't replaced the fuel pump and filter, than that's a good idea too.
Good to know, so essentially the car should start everytime without a problem with the MAF unplugged , if only the MAF is faulty correct?

What happens when you drive with the MAF unplugged ?
dee0007 is offline   Reply With Quote
Old 01-11-2014, 06:17 PM   #8
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,951
Quote:
Originally Posted by dee0007 View Post
Good to know, so essentially the car should start everytime without a problem with the MAF unplugged , if only the MAF is faulty correct?

What happens when you drive with the MAF unplugged ?
On some, if not all automatics it will go to limp mode and not go over 30km/h...
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 01-12-2014, 08:25 AM   #9
Couwks325i
1st Gear Newbie
 
Couwks325i's Avatar
 
Join Date: Feb 2010
Location: Toronto, ON
Posts: 6
I have the same issue, I suspect a leaking fuel injector. I have not yet t/s to see which one, so far I'm living with it.
Looking for the new updated injectors which do not deform below. -15degC and spew fuel vapor into the engine bay, get sucked into your cabin by the blower fan :-(

Sent from my Android using Tapatalk 2
Couwks325i is offline   Reply With Quote
Old 01-13-2014, 07:00 AM   #10
cheapthrills
2nd Gear Member
 
Join Date: Feb 2012
Location: Toronto
Posts: 100
Quote:
Originally Posted by dee0007 View Post
It does hesitate only on second gear between 2500-3000rpm. It chokes.
Is this consistent? Does it buck back and forth? What year is your car? My MS45.1 330ci had a buck/stutter as well as an occasional long crank (or indefinite crank). Both of the issues were solved when I updated my software. If your car is 04+, I'd try that.
__________________
cheapthrills is online now   Reply With Quote
Old 01-13-2014, 07:32 PM   #11
G12
G12
 
Join Date: Jan 2013
Location: Base Borden/Barrie
Posts: 54
Quote:
Originally Posted by cheapthrills View Post
Is this consistent? Does it buck back and forth? What year is your car? My MS45.1 330ci had a buck/stutter as well as an occasional long crank (or indefinite crank). Both of the issues were solved when I updated my software. If your car is 04+, I'd try that.
What does "occasional long crank (or indefinite crank)" mean?
__________________
G12 is offline   Reply With Quote
Old 01-14-2014, 06:46 AM   #12
cheapthrills
2nd Gear Member
 
Join Date: Feb 2012
Location: Toronto
Posts: 100
It means that sometimes it would crank for 5-10 seconds before starting, and sometimes it would just keep cranking, and if I cycled the key off and tried again, it would start normally.
__________________
cheapthrills is online now   Reply With Quote
Old 01-14-2014, 06:37 PM   #13
G12
G12
 
Join Date: Jan 2013
Location: Base Borden/Barrie
Posts: 54
How would one go about a software update?
__________________
G12 is offline   Reply With Quote
Old 01-14-2014, 10:38 PM   #14
ac_2007
Cruising in Top Gear
 
ac_2007's Avatar
 
Join Date: Aug 2011
Location: Toronto, ON
Posts: 640
1) Unplug MAF, try starting and see how it drives. Your car will run rich while its unplugged (more fuel)

2) Change fuel filter. If you haven't already, by your mileage you're OVERDUE.

3) Add 2 bottles of Chevron Techron (BMW fuel system cleaner)

4) Check Fuel Pump pressure.

5) Check injectors (Although Techron should help)

6) Check coil packs/sparkplugs

Do it in that order, the first items are free/needed anyways.
__________________
ac_2007 is online now   Reply With Quote
Old 01-15-2014, 06:57 AM   #15
cheapthrills
2nd Gear Member
 
Join Date: Feb 2012
Location: Toronto
Posts: 100
Quote:
Originally Posted by G12 View Post
How would one go about a software update?
This is what I did:
http://forums.bimmerforums.com/forum...7#post25106307

You can also take it to a dealer or BMW Independent shop, and it'll be ~1 hr labour. I can also do it, but you'd need to supply a battery charger.
__________________
cheapthrills is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.