Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-08-2013, 05:46 PM   #1
John M3 Conv
1st Gear Newbie
 
Join Date: Feb 2011
Location: Toronto
Posts: 7
M3 TPMS Error Light

I have a 2004 M3 Convertible with SMG transmission with under 70k. My problem is I have had the Tire Pressure Monitoring System error light on for almost a year now. I have had both my mechanic and two different BMW dealer's look into it and they can't find any faults on the computer. They can reset it but as soon as I am on the highway it comes back on. It does not come on when driving in the city. Tires are brand new and there are no other issues. It's annoying seeing the red error light on my dash and was hoping someone can point me in the right direction or have any suggestions on how to resolve this issue? Any feedback would be greatly appreciated.

Last edited by John M3 Conv; 06-08-2013 at 06:18 PM.
John M3 Conv is offline   Reply With Quote
Old 06-08-2013, 06:49 PM   #2
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,307
Are you using non stock sized tires? E46 m3s use the abs sensors to tell if one tire is rotating slower and losing pressure. Could be a sensor giving a bad reading or your tire sizes are off??
__________________
T.Dot_E30 is online now   Reply With Quote
Old 06-08-2013, 06:53 PM   #3
John M3 Conv
1st Gear Newbie
 
Join Date: Feb 2011
Location: Toronto
Posts: 7
T.Dot-Good Point I forgot to mention I am using stock tires and rims.
John M3 Conv is offline   Reply With Quote
Old 06-09-2013, 01:13 AM   #4
jabela
4th Gear Member
 
Join Date: Apr 2007
Location: Toronto, ON, Canada
Posts: 747
How about your tire pressures? Are they all even?
Could you let us know what size tires are on front/rear?
If all that is good, then you may have an ABS sensor issue.
Check the tone rings to make sure they're clean and no teeth are broken off.

Failing that, I don't trust dealers, so take it to Rocco at RMP Motors. Then let us know what it was.
Good luck!
__________________

2002 E46 325ci // 5spd // ISC N1 Coilovers
www.modernapothecary.ca
jabela is offline   Reply With Quote
Old 06-10-2013, 12:29 PM   #5
leftbank
1st Gear Newbie
 
Join Date: Apr 2009
Location: Toronto
Posts: 15
seized/seizing caliper? happend to me recently TPMS kept going off as well.
leftbank is offline   Reply With Quote
Old 07-23-2013, 07:25 PM   #6
John M3 Conv
1st Gear Newbie
 
Join Date: Feb 2011
Location: Toronto
Posts: 7
Here is an update to my problem being solved.
My mechanic did some research and found that BMW has a TSB on this issue for the TPMS as they had many customers that had issues.
It’s been a month now and no more issues with the light once I reset it.
Here is the TSB stating alternative re-setting procedure.
Followed the following BMW recommended procedure:
1. Check Tire Pressure to make sure no variance from side to side.
2. Sit in car, with out touching the pedals.
3. Key in ignition, Turn key on to engine off position (second position).
4. Press and hold TPM until TPM lights go out completely on the dash.
5. Press and hold TPM again until yellow TPM light indicator comes lit on dash.
6. Start car and drive. Light will go off itself once it has calibrated tire pressure.
(might go out at idle).
John M3 Conv is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:19 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.