Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 06-13-2013, 09:12 PM   #1
_JohnnyD_
2nd Gear Member
 
_JohnnyD_'s Avatar
 
Join Date: Jul 2010
Location: The Creek
Posts: 134
My M60 powered E30

I took my E30 out on another shakedown run today and I thought I would take a few pictures and post with a few specs. (sorry for the cell pics and the dirty car but it's not ready for a big photo shoot anyways)




I bought the car 3 years ago as a shell. (big mistake buying a shell) The body was very clean but every bolt on panel was rusted out badly and has been replaced.



The car started life as a lachsilber 1990 325i auto coupe.

The specs as it sits today.

Painted BMW British Racing Green (same as E36 M3 GT and some E34 M540s). The pictures don't do the colour justice because it was dark out on both days.



M60B40 engine. The mounts are Johnny D specials. The subframe is in its original spot and the pan is not notched.
6 spd trans from a E39 540. The flywheel, clutch and shift parts are all OEM E39 M5 stuff.
It is running a 3.25LSD diff right now but 1st is very short so we'll see how long that lasts.



The brakes are all stock E30 parts with Zimmerman rotors and Hawk HPS pads. I went with the E34 remote booster but no linkage. I mounted the booster on a 13 deg angle from the centre line and modified the pedal mount to match. I connected the pedal and booster with a 12mm OD steel shaft and a pivot on the booster side. It works well so far.



For cooling I tried a E28 535 rad but the rad I have leaks and I didn't like the hose configuration. Now I'm using 2.5" thick aftermarket Toyota Celica GT4S rad. The rad has a greater surface area then a E28 or E36 M3 rad because it doesn't have end tanks, they are top and bottom mounted. The centrally mounted spout also clears the oil filter nicely. I have a 16" ebay pusher fan mounted. (I just found out its not working so I'll have to do some digging)



The suspension is all new. It sits on a 60/40 ST kit with Tokico shocks (temp stuff until I decide what to do in the long run) and it has Eibach sway bars.

The wheels and tires are VW Corrado 15" steelies widened to 8.5 up front running 205/50 tires and 9.0 out back running 225/50 tires.

The interior is still a mess but at least usable. I have a 14" wood Dino wheel and VW MKII valour Recaro seats on Johnny D mounts.



That's all I can think of right now.

The car runs fine however the fan is not working and the alignment is way off. It also has an ABS light that I really don't want to chase right now.

I'll get these little things sorted out then I need to get it safetied and e-tested.

Let me know what you think.
__________________
“Life is a series of experiences, each one of which makes us bigger, even though sometimes it is hard to realize this...”

Henry Ford
_JohnnyD_ is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:08 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.