Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-01-2013, 09:22 AM   #16
dd330i
1st Gear Newbie
 
Join Date: Jul 2012
Location: GTA
Posts: 2
O2 sensor?
dd330i is offline   Reply With Quote
Old 05-17-2013, 02:59 PM   #17
johnbmw
1st Gear Newbie
 
Join Date: Apr 2013
Location: whitby
Posts: 11
I need a good BMW mechanic.. someone who knows these cars inside out.

I just finished spending $2800.00 and the problems is still there.

Replaced by BMW..

fuel pump
repair kit version
return pipe
guide tube
o ring
vacuum hose
vent hose
dipstick
adjuster unit
johnbmw is offline   Reply With Quote
Old 05-17-2013, 03:08 PM   #18
johnbmw
1st Gear Newbie
 
Join Date: Apr 2013
Location: whitby
Posts: 11
This is a reply to erostyle:

These were all checked as well.

I would look for vacume leaks, sometimes under hard acceleration the engine will move (also check engine mounts!) and a cracked intake boot will suck in air...causing a missfire.

Also check camshaft sensors, they tend to do the same.
johnbmw is offline   Reply With Quote
Old 05-17-2013, 05:19 PM   #19
Dinanstu
2nd Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 298
Get the codes.

I still believe its electronic and the ECU is putting the car in limp home mode. Yours is AWD, so it could be a tranny safem mode...

Guessing isn't helpful, get the codes.

So to recap, the car always loses power when you turn into corners and never at any other time?

Did I mention to get the codes?
__________________
loving the ride!
Dinanstu is offline   Reply With Quote
Old 05-17-2013, 06:40 PM   #20
damameke
6th Gear Member
 
Join Date: Dec 2008
Location: Canada
Posts: 1,367
Quote:
Originally Posted by johnbmw View Post
I need a good BMW mechanic.. someone who knows these cars inside out.

I just finished spending $2800.00 and the problems is still there.

Replaced by BMW..

fuel pump
repair kit version
return pipe
guide tube
o ring
vacuum hose
vent hose
dipstick
adjuster unit
If I spent that much money and the repair was based on what you have told them, and it was not resolved.. I would be speaking to the service manager, before I opt for indy...which dealership is that?; so I know where not to go....
damameke is offline   Reply With Quote
Old 05-24-2013, 03:17 PM   #21
johnbmw
1st Gear Newbie
 
Join Date: Apr 2013
Location: whitby
Posts: 11
Problem fixed:

Here Guys, if you ever experience an issue like this.

It turned out to be my coils. 4 out of 6 were misfiring on hard acceleration so the chip shut them down. By restarting the car it cleard the fault.

Well I'm back on the road again and can finally pass a Hyundai.

Thanks for all your advise.
johnbmw is offline   Reply With Quote
Old 05-24-2013, 10:40 PM   #22
windwagen
6th Gear Member
 
windwagen's Avatar
 
Join Date: Jul 2004
Location: Markham
Posts: 1,805
Please tell me the dealer didn't charge for the non fixes!
windwagen is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.