Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-01-2013, 02:36 PM   #1
on the roam
Join Date: Jun 2008
Location: Ontario, Canada
Posts: 347
e39 radiator drain plug/hose leaking

e39 540i experts: Need your help.
I drained the coolant from the engine block (2 bolts) and the radiator last night, but I have the type of radiator that doesn't have a drain plug but a small plastic angle connector attached to a rubber hose. You twist it 1/4 turn and pull out the connector to drain.
With the connector back in, there is residual coolant leaking at the connection point
Did an o-ring fall out, or is there a part option to seal this up properly? I can't refill the radiator until I fix this....

Any specifics, please advise (e.g. part #'s), nothing on realoem helped me.
gnome is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 08:30 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015