Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-10-2012, 02:42 AM   #1
Hal900x
1st Gear Newbie
 
Join Date: Oct 2012
Location: Southern California
Posts: 4
CSB Preload?

I had been hearing a worsening clatter from directly below my handbrake/center console area while under torque. Sure enough, the CSB bracket was cracked and the crack had run into the actual assembly a bit too.

After replacing it and the Guibo, the same issue except the sound was now higher pitched and different in tone, but similar symptoms. The same cadence, if you will, and mostly when under torque. For whatever reason it has never occurred in reverse gear. We scratched our heads a bit and decided I had bad U-Joints that were either responsible for the sound themselves (at least in part) and/or immediately damaging the new CSB and thus the repeat symptom.

Tonight my buddy said he had the answer, which is that we failed to preload the CSB and it had shredded itself. We simple centered the bolts in the slots and tightened them down, when we should have pushed it forward and then tightened. I would like some input before I order another one and go through the whole mess again. Do you think a failure to preload would cause immediate major damage to the CSB? What kind of damage would you expect? He felt that not preloading would shred the rubber, but the old CSB was cracked mainly in the bracket and a bit into the assembly itself.

Thanks a lot for the feedback.
Hal900x is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.