Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Z series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-07-2012, 06:13 PM   #1
accent
1st Gear Newbie
 
Join Date: Nov 2012
Location: Hamilton, ON
Posts: 5
Gas Gauge Problem

Hi
Bought a 2003 Z4 2.5i from a dealer and the gas gauge didn't work; it only would move to half full when it was filled.
The dealer got a new sender unit (connected to the fuel pump - more than $400) but on further inspection the mechanic saw another sender in the tank.
When he questioned the BMW dealership about this, they told him it is a programming problem.
The dealer has been fine paying for everything, but I am left wondering if this is a common problem with the Z4, and if it is a programming problem
Thanks in advance for any info.
accent is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014