Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Specific Regional Topics > Quebec/Gatineau/Ottawa
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rating: Thread Rating: 2 votes, 3.00 average. Display Modes
Prev Previous Post   Next Post Next
Old 09-16-2012, 05:09 PM   #11
sb_600
5th Gear Member
 
sb_600's Avatar
 
Join Date: Apr 2010
Location: Ottawa, ON
Posts: 1,183
Friday was the last gentlemen's race of the year - and it was a WET one!

I was pretty happy because it meant I finally had a chance to try my rain-grooved R888s that I bought 2 years ago.

Just as I was about to head out for qualifying, I tried my wipers and found out they weren't working (passenger one was too low and getting stuck on the windshield). By the time I removed it, I had missed about 1/2 of the 25 min session.

I head out, and instantly my windshield fogs up to the point where I can BARELY see the track - talk about scary! I come into the pits, dad wipes off my windshield, and it happens again (not as bad though). I do another lap, then come in again. Dad wipes it off and I go back out - do 1 lap and get checkered flagged.... ugh - ended up qualifying last in GT1 with a 1:42.2.

Turns out Jamie was having the same issue - I knew we had to do something.... I found a bottle of armor all, and figured, what have I got to lose? Sprayed it on the windshield, smeared it in a bit, and crossed my fingers.

Race time! now that I have a clear winshield, things are looking better (pun intended). Green flag drops, and I start getting in the groove. Lap after lap I gain on the cars in front - my car, for what seems like the first time this year, is handling AWESOME. I got a quick alignment done friday morning and it seems to have paid off!

Anyways, by the end of the race, I was in 2nd!!! I'd moved through the whole field. My lap times were consistently in the 1:34 +-1 except for a few where I got down to the 1:30s - 12 seconds faster than qualifying!

It was a ton of fun and a great way to end the series. Next stop, Mosport on Oct 8!

__________________
Shawn
1992 BMW 325i (CHUMPCAR #296 - Metric Homes Racing)
1992 3.0L M52 325i (ex-daily driver - track car only)
2002 330Ci (ex-daily driver - sold!)

sb_600 is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.