Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Audio/Sound
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 09-13-2012, 11:25 PM   #1
wolf_e39
2nd Gear Member
 
wolf_e39's Avatar
 
Join Date: Apr 2012
Location: toronto
Posts: 221
e39 stock radio problem

hey guys recently i got a new head unit for my e39 and i am having a bit of a problem
i have taken the stereo out before so i know how to do it but this time its not working.

i believe i broke the screw underneath the power/volume button so the stereo does not pop out

my question is how do i do i it now how do i remove it? is there a way to pop it off by pushing it from the back or something ?

thank you in advance
wolf_e39 is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:04 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014