Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Classifieds > Looking for
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 08-27-2012, 07:12 AM   #1
Bullet Ride
Cars in Perpetual Repair
 
Bullet Ride's Avatar
 
Join Date: Nov 2007
Location: Guelph
Posts: 5,741
LF: E30 front subframe KW area ASAP

The right side motor mount on my front subframe broke yesterday. The thing didn't look that bad from the outside, but it was rotting from the inside out and lapping on r-comps was what did it in.

Anyone in the KW area have an E30 parts car?
__________________

Last edited by Bullet Ride; 08-27-2012 at 08:34 AM.
Bullet Ride is online now   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:03 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014