Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-17-2012, 03:13 PM   #1
Stefan11
1st Gear Newbie
 
Join Date: May 2009
Location: Guelph/Ottawa
Posts: 39
E30 won't run, no spark, no fuel.

I haven't done much to my E30 since fall and now it doesn't run. There is no fuel or spark. I jumped the fuel pump relay and I have fuel pressure. The car is an 86 with the sensors on the bellhousing. I swapped out the two sensors and nothing has changed. Before I delve into the car and its problem, does anyone have any quick ideas? What seems most important is that BOTH spark and fuel pressure are affected. One day the car ran, the next day it didn't......

Thanks in advance

Stefan
Stefan11 is offline   Reply With Quote
Old 04-17-2012, 04:43 PM   #2
El Gato Liso
6th Gear Member
 
El Gato Liso's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 3,116
fuse 11
__________________
R.I.P. E30
El Gato Liso is offline   Reply With Quote
Old 04-17-2012, 04:53 PM   #3
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,413
Main Relay (engine bay)
Fusible Link
Fuse (Call all)
Bad ECU
Crank Sensor

These are potential issues that you need to troubleshoot and eliminate one by one in a no start case with no spark or fuel.

Basically ECU is not getting the signals it needs to send spark and trigger the fuel pump.
__________________
T.Dot_E30 is offline   Reply With Quote
Old 04-17-2012, 05:05 PM   #4
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,378
do you hear the fuel pump engage with the ignition on. Bad fuel pump will give pressure but maybe insufficient.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is online now   Reply With Quote
Old 04-17-2012, 05:14 PM   #5
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,413
Quote:
Originally Posted by Ceeker View Post
do you hear the fuel pump engage with the ignition on. Bad fuel pump will give pressure but maybe insufficient.
Wouldn't cause no spark if it was the pump...
__________________
T.Dot_E30 is offline   Reply With Quote
Old 04-17-2012, 05:29 PM   #6
Stefan11
1st Gear Newbie
 
Join Date: May 2009
Location: Guelph/Ottawa
Posts: 39
The fuel pump is okay, I have pressure when I jump the relay. I have changed the crank position sensor. I will search and find the main relay and fuseable link. Can I assume that the main relay is controlled by the key? Where in the circuitry is the fuseable link? I ask because I do have power to the fuse panel.

I am away from home and won't get back to the car until this week-end. It would be nice to have the 325 serviceable once again!
Stefan11 is offline   Reply With Quote
Old 04-17-2012, 06:10 PM   #7
Stefan11
1st Gear Newbie
 
Join Date: May 2009
Location: Guelph/Ottawa
Posts: 39
I checked all the fuses however I will check fuse #11 again
Stefan11 is offline   Reply With Quote
Old 04-17-2012, 11:40 PM   #8
matty.dc
5th Gear Member
 
matty.dc's Avatar
 
Join Date: Feb 2008
Location: Hamilton
Posts: 1,108
Send a message via MSN to matty.dc
It will most likely be your crank position sensor. I would start by checking the resistance on that sensor(supposed to be around 550ohms I believe). The symptoms are the same. It cuts fuel and spark at the same time. If you were to check your injectors for a pulse from the DME and it was absent, that would for sure tell you it is in fact the CPS.
__________________

1987 325is(Midnight Tuning Tuned OBD I S52) - Current Summer Car
2012 Hyundai Veloster Tech- Daily Driver
1985 318i - 1st Car (started it all)
matty.dc is offline   Reply With Quote
Old 04-18-2012, 12:29 AM   #9
InfiniteDice
14 Years with the E30
 
InfiniteDice's Avatar
 
Join Date: Sep 2006
Location: St. Catharines
Posts: 1,126
Let's not forget that the sensors on the bell housing look for the little magnet on the flywheel. If that's missing it won't run.

But yeah, check the fusible link in the trunk, one quick way to do that is check for volts on the small lead that comes off the battery, disconnect it from the terminal under the hood on the passenger side firewall... then test to ground.
__________________




Performance one step at a time.
InfiniteDice is offline   Reply With Quote
Old 04-18-2012, 12:30 AM   #10
InfiniteDice
14 Years with the E30
 
InfiniteDice's Avatar
 
Join Date: Sep 2006
Location: St. Catharines
Posts: 1,126
Also if it's automatic it could be the park safety switch.

Does it have an OBC with the start code flashing? lol
__________________




Performance one step at a time.
InfiniteDice is offline   Reply With Quote
Old 04-19-2012, 12:23 AM   #11
E30M42cab
Parts Hoarding Specialist
 
E30M42cab's Avatar
 
Join Date: Apr 2006
Location: Milton
Posts: 2,333
Can you do a stomp test on a 86?
__________________

Quote:
Originally Posted by richie_s999 View Post
Grow up and move on.
E30M42cab is offline   Reply With Quote
Old 04-19-2012, 07:50 AM   #12
Stefan11
1st Gear Newbie
 
Join Date: May 2009
Location: Guelph/Ottawa
Posts: 39
What is a stomp test?
Stefan11 is offline   Reply With Quote
Old 04-19-2012, 08:35 AM   #13
El Gato Liso
6th Gear Member
 
El Gato Liso's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 3,116
^^^^

turn key on into accessory

stomp on the gas pedal 5 times

and the Check Engine light on the cluster comes on, and flashes, the number of blinks it makes is equivalent to a number. it read out fault codes, if there are any.

its pretty cool...helped my dumbass out after cutting of my diagnostics port -_-
__________________
R.I.P. E30
El Gato Liso is offline   Reply With Quote
Old 04-19-2012, 08:59 AM   #14
Stefan11
1st Gear Newbie
 
Join Date: May 2009
Location: Guelph/Ottawa
Posts: 39
I will try the stomp test this week-end......
Stefan11 is offline   Reply With Quote
Old 04-19-2012, 10:05 AM   #15
Deetow
2nd Gear Member
 
Join Date: Jun 2009
Location: Toronto
Posts: 150
Quote:
Originally Posted by El Gato Liso View Post
^^^^

turn key on into accessory

stomp on the gas pedal 5 times

and the Check Engine light on the cluster comes on, and flashes, the number of blinks it makes is equivalent to a number. it read out fault codes, if there are any.

its pretty cool...helped my dumbass out after cutting of my diagnostics port -_-
If it Returns 1-4-4-4 it means it has no saved faults.
Deetow is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:20 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014