Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-07-2012, 12:06 AM   #1
InfiniteDice
14 Years with the E30
 
InfiniteDice's Avatar
 
Join Date: Sep 2006
Location: St. Catharines
Posts: 1,126
dual OEM fuel pumps - gone.

Swapped to a single walbro today, was a bitch to get in the tank but with a little determination and repositioning it went in.

Definitely harder than some 'online' stories may suggest. The low pressure line from inside the tank is fat, and you need to step it down to the walbro pump. That makes it very difficult (especially on a holiday when you can't buy anything).

My only concern and one that I'm going to fix tomorrow is that the leads going to the in tank pump are a bit on the small side like 16 or 18 gauge, and I think the Walbro I crammed in there needs around 12 amps at max. I'm thinking since I pulled the external pump leads inside the car and taped them up under the seat I'll just extend those and integrate them into the new pump, as they are beefier. They all run on the same circuit anyways @15 amp.

Running good so far.
__________________




Performance one step at a time.
InfiniteDice is offline   Reply With Quote
Old 04-07-2012, 12:03 PM   #2
karmatose
164.3ci Of Fury
 
karmatose's Avatar
 
Join Date: Jun 2011
Location: London
Posts: 377
Let me know what you think of this setup. I'm giving serious consideration to doing similar.
karmatose is offline   Reply With Quote
Old 04-07-2012, 08:45 PM   #3
InfiniteDice
14 Years with the E30
 
InfiniteDice's Avatar
 
Join Date: Sep 2006
Location: St. Catharines
Posts: 1,126
Okay I'll repost and be sure to include some tips. There are a few things I learned and a few items I wished I had gathered ahead of time.

I have about 12-13 hours of driving to do on Monday so that will be a good test
__________________




Performance one step at a time.
InfiniteDice is offline   Reply With Quote
Old 04-07-2012, 10:44 PM   #4
karmatose
164.3ci Of Fury
 
karmatose's Avatar
 
Join Date: Jun 2011
Location: London
Posts: 377
Brilliant, man... I'd really appreciate any feedback/tips you can offer.
karmatose is offline   Reply With Quote
Old 04-11-2012, 10:24 AM   #5
InfiniteDice
14 Years with the E30
 
InfiniteDice's Avatar
 
Join Date: Sep 2006
Location: St. Catharines
Posts: 1,126
Trip to Ottawa went fine, did about 11 hours of highway and 1.5 hours of inner city driving.

Contrary to what people might think turning the key to the 2nd position doesn't activate the pumps, only when the key is turned to 'start' do the pumps come on. I can tell because the walbro has a whirring noise. It's not too noisy but if you have a bone stock silent e30 you may notice it more. With my exhaust it's not an issue!

I'll get a few photos on here with a post outlining the tips soon.
__________________




Performance one step at a time.
InfiniteDice is offline   Reply With Quote
Old 04-11-2012, 10:35 AM   #6
karmatose
164.3ci Of Fury
 
karmatose's Avatar
 
Join Date: Jun 2011
Location: London
Posts: 377
Photos would be SWEET. Also, good to hear it's working well for you.

I have a Stebro exhaust on my ride so I'm gonna imagine that I'd never hear the Walbro pump should I do the swap. However, this is all speculation as I've not driven my E30 let alone start it yet.. LOL.
karmatose is offline   Reply With Quote
Old 04-11-2012, 01:24 PM   #7
InfiniteDice
14 Years with the E30
 
InfiniteDice's Avatar
 
Join Date: Sep 2006
Location: St. Catharines
Posts: 1,126
Moved it to a new topic. http://www.maxbimmer.com/forums/showthread.php?t=150045
__________________




Performance one step at a time.
InfiniteDice is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:37 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.