Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-10-2012, 12:37 PM   #1
jmack
2nd Gear Member
 
Join Date: Mar 2009
Location: Trent Hills
Posts: 191
540 catalytic converters failing?

Hey guys,

Wondering if anyone has replaced the cats in their 540 and why... A couple weeks ago the car died on me after a half-hour trip, it would start, then die right away. Seemed to be getting fuel, spark, etc, but would just crap out at idle. I could keep it 'going' with foot on the gas, but that didn't really get me anywhere.

After getting it towed home I can start it and it will run, albeit somewhat weakly with a lower than normal idle, would dip to 400-300 and sometimes less. I haven't been driving it at all as I am fearing getting stuck again.

Listening at the rear exhaust you can hear a pronounced vibration that comes and goes, comes and goes.

Does this sound like a clogged or otherwise toasted cat(s)?
jmack is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:22 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.