Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 03-28-2012, 07:12 PM   #1
Wuzie
2nd Gear Member
 
Wuzie's Avatar
 
Join Date: Dec 2011
Location: Ottawa
Posts: 180
M20 Uses 40L/100km at Idle!!

Hey guys.. my car has been through a bit of mishap. The fuel rail was leaking previously. I swapped the rail from an eta engine, of course the holes didnt line up, we rerouted things around. Kept my blue top injectors and fuel pressure regulator. This fixed the leak, hooray.

Everything was dandy aside from my vacuum leaks. I was getting shitty mpg (around 8mpg honestly) and once I fixed everything, swapped a new elbow intake boot piece, but that was also from an eta engine.. so things didnt line up properly. This fixed the idle for a bit, but then fuel economy was bad again, so I put my stock boot piece back on and taped every leak as well as clamped them shut.

This worked! Started to get down to 8.8L/100km and right now it averages about 20-23mpg while driving. However, at idle, I see the little needle showing consumption shoot all the way to the end. And once I reset the thing on the OBC, it shoots up to 40L/100km !

Whats going on here? Can anyone relate or help me out please?
__________________
Wuzie is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.