Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-27-2011, 08:34 PM   #1
webb70
3rd Gear Member
 
webb70's Avatar
 
Join Date: Jun 2009
Location: Milton
Posts: 370
WTF just happened......

2002 330CI (Steptronic)

I get in my car and am driving to work and my radio starts cutting in and out, so I turn it off. Then I was driving down the hyway at around 110KPH when all of a sudden I hear/feel a clunk from my car, I look down at my dash and both the Traction control lights are on, the ABS light is on, there is no radio display and no climate control display???
I continue to drive as I take the next exit and there doesn't seem to be any loss of power or anything, I try switching to sport mode and it does, but when I try to shift the car stayes in SD and does not go to Manual mode. When I get off the hyway and stop at the lights I look under the car but see no leaks or smoke. When I pulled away from the lights its obvious that the car is still in a high gear and pulls away slowly.......
Any thoughts/ Ideas ??

Thanks in advance
__________________
webb70 is offline   Reply With Quote
Old 10-27-2011, 09:22 PM   #2
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,951
Alternator...if it goes bad the radio will stop, other electronics will not function right...
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is online now   Reply With Quote
Old 10-27-2011, 09:43 PM   #3
webb70
3rd Gear Member
 
webb70's Avatar
 
Join Date: Jun 2009
Location: Milton
Posts: 370
Quote:
Originally Posted by Eurostyle View Post
Alternator...if it goes bad the radio will stop, other electronics will not function right...
Thank you Sir...do you have one in stock??
__________________
webb70 is offline   Reply With Quote
Old 10-27-2011, 10:07 PM   #4
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,951
Yes i do, but get it tested first to make sure this is the problem.
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is online now   Reply With Quote
Old 10-27-2011, 10:26 PM   #5
webb70
3rd Gear Member
 
webb70's Avatar
 
Join Date: Jun 2009
Location: Milton
Posts: 370
I just went out and checked the belt and its still there and looks good, so I started the car and now everything works except the radio.
I put the car in gear and switched to manual and it went in fine. The ABs light is off, the TC lights are off, and the climate control display is back on. The radio lights up but when I turn it on it only plays a muffled bass.....
I'll take it in tomorrw and have it checked out, Thanks for your help.
I will call you tomorrow if I do need an alternator.
__________________
webb70 is offline   Reply With Quote
Old 10-28-2011, 10:53 AM   #6
radi0activem
3rd Gear Member
 
Join Date: Jan 2010
Location: Ottawa, ON, Canada
Posts: 309
Same thing happened to me. Ended up being the alternator.
Put a multimeter on the battery with the car off, take note of the voltage. Then start the car and take note of the voltage.

let us know what you get.
__________________
Brian
------------
2003 530i
radi0activem is offline   Reply With Quote
Old 10-31-2011, 06:18 PM   #7
webb70
3rd Gear Member
 
webb70's Avatar
 
Join Date: Jun 2009
Location: Milton
Posts: 370
So it turns out it was the alternator....
Replaced it today with one from Eurostyle and it looks like all is well now....

Thanks for your help Sir.
__________________
webb70 is offline   Reply With Quote
Old 10-31-2011, 08:55 PM   #8
Blackedout95
5th Gear Member
 
Join Date: Feb 2009
Location: Canada
Posts: 1,082
This is a cool thread
__________________
E46
Blackedout95 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:11 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.